10 Camera System Lag


#1

Hello Henrik! I did finally buy your software and got all my cameras installed.

We are now running 10 hikivision 4mp cameras!

Now like before in our previous thread:

I’m having the issue where files skip over huge amounts of time.

Now the first test was in full 4MP res. Up to 3 cameras it was fine. After that the computer basically became unresponsive. 100% CPU usage and very low disc usage.

No compression, i7 with hyper threading, WDD gold.

Now that was a little unfair. I changed resolution to 1080p. Up to 6 cameras it was fine. After that it died.

I still have more trouble shooting to do including max bit rate, but what options do we have to try to optimize and work on this.

Multi core is checked as well.

I’m here on the forums all weekend, but am back where the cameras are on Monday. I’ll do any trouble shooting you need as you may not have 10 of these high resolution. Just let me know!

Thanks,
Corey


#2

Hi Corey,
Running 10 cameras in 4MP is a lot!! What i7 processor is it?
I am away for the weekend and back on Sunday night.
-Henrik


#3

I believe it is the i7-4770k

I toned them down though. So 1080p should be doable… maybe not though?


#4

If you compare the i5 and the i7 processor like here http://cpuboss.com/cpus/Intel-Core-i7-4770-vs-Intel-Core-i5-6300HQ the difference is that the i7 have 4 more virtual processors with an increased performance of maybe 30% looking at the benchmark for all cores.
Running the i7 was fine with:
-3 cameras in 4MP, 2688 x 1520 pixels. 8 threads
-6 cameras in 2MP, 1920 x 1080 pixels, 8 threads

Interesting pattern here. I have no idea if this is linear or whatever, but:
-10 cameras in 4MP would need a processor with 28 threads
-10 cameras in 2MP would need a processor with 14 threads

I know that new i7 processors have 8 cores and 16 Threads which might work, but 14 cores and 28 Threads I do not know.

We have a similar discussion here 50% cpu for Intel i5-7400, CRF 30, Ultrafast, at 10FPS. What can I do about it? moving to other processors like Intel Xeon processors with many cores/threads. You can buy a server system that is a couple of years old with a very good processor to a very reasonable price. I am myself looking a this solution for a 21 camera system with varying resolutions is running a xeon e3 1220v3 processor with 4/4 at a cpu load of 95-100%. I like the xeon processor for the ECC in RAM. Other alternative is 2 computers, but then there are 2 NCS so that depends on the application if that works. Preferably is of cause only 1 NCS to have all cameras in one system.

-Henrik


#5

Hello Henrik,

I have lowered the resolution on almost all the cameras. Now I have

4 @ 720p
4 @1080p
2@4MP

Though there is still some high resolution, I am trying to NOT record with all of them at once. Instead I am using motion detection.

It appears however, that having motions detection on puts as much strain on the system as regular recording.

I assume this is because the program is designed to record a few seconds before motion is detected, so it’s always being recorded.

How can either.
A. Remove this “pre record” and only start saving to memory once motion is detected.
B. Heavily reduce the CPU usage that motion detection causes.

Thanks,
Corey


#6

Henrik,

Doing more reading, I think a “Direct to disc” option would probably solve a lot of this. How does your software currently write things to the harddrive? I notice that my disc usage is fairly low when it should be very high.


#7

Corey,

Actually, we are just having the discussion about using the raw format. This will be a licensed feature since the possibility for an overlay is removed. The raw format takes about 10 times more space on the HD (if I remember correct), but if that is not a problem then …
A. pre-recording is fixed to 50 frames and cannot be removed as of today and is hosted only in RAM.
B. motion detection itself do not use that much resources. It is the conversion for adding overlays that take cpu power.
C. in the configuration of motion detection there is a frame interval that is 200 msec. Try to increase that.
D. In the tab for Recording I assume that it is set to Superfast. Try to laborate with the video quality also.

In the meantime I hope we can survive :wink:
-Henrik
@Steve