Accessing camera Foscam C1 for video and audio at remote location


#1

I have a Foscam c1 lite at a remote location (separate from my other cameras which are all at same location)…I have opened the port at the remote location and forwarded it to the local ip address. I now want to access it through NetcamStudio…I have added the camera as I would any other camera using template for Foscam C1…and enter the LAN ip of the remote location and cant connect…

If I type the url in my browser :http://lanip:port I access it fine…

I need some help.


#2

correction…I type in my browser

http://wanip:88 (not the lan)


#3

Hi Nick,
Two things:
1.in the template, did you change Port from 80 to 88?
2.if 1 is ok what windows version are you running?
-Henrik


#4

Yes…changed it to port 88 and running windows 7


#5

Hi again,
I see that the template work with the RTSP streem so you need to change like this.

Or if it runs on RTSP port 554? I am getting a little uncertain here. In that case you need to port forward port 554 in the router also. Foscam sometimes work with port 88 for rtsp so you have to test.

-Henrik


#6

Summary of our efforts.
Foscan C1 is one of those problematic cameras that the access to changes with firmware and whatever else. This time the template for the C1 with rtsp did not work. So far the template for Foscam FI9821W V2 set to JPEG works. This is for jpeg and therefore slow. Somewhere it says that it support ONVIF. Test that also.
-Henrik


#7

Thank you for the help…I did manage to logon to the camera using the foscam software and enabled the ONVIF but I must admit I am not familiar with ONVIF and appreciate it if you could tell me about it and how to use it.

Many thanks

Nick


#8

Excellent. This will be interesting.
See figure below.
0.ONVIF only works on LAN so you must have the camera on the same LAN as the computer.
1.add a new camera
2.use the tab ONVIF Source
3.click on Browse to find the source. If it is not there write the IP number in the field Unknow/Custom.
4.enter logins.
5.click on Get Profiles. Now in the field ONVIF Profiles there should be one or more choices that you can select depending on what the camera can deliver. Select one and click on 7.

If everything is fine you should see the video from the camera. ONVIF is a standard, but it is not always that the manufacturers blow that to a 100%, but for video it is usually no problems.

When this is working you can go back to this configuration, but this time go to the tab Custom URL. There you can see the exact URL that the is used for the communication. That is very interesting to have here in the forum.

Good luck and please report back how it goes,
Henrik


#9

Thank you for the help…Unfortunately the Foscam camera is at a remote location from my computer so I will have to physically move the camera to try and set it up with ONIV. WIll need some time to try that out…


#10

Ok, but I have another solution. If you have access to a computer in the remote location do this.
-install a version of NCS on the local machine and add it using the onvif tab. and find the url in the tab for custom url.
-alternative is to download ONVIF DEVICE MANAGER.
-install and run and ODM detects the camera if it supports onvif.
-here you find the url to use

-Henrik


#11

Great…will give it a try and report back


#12

ONVIF picked up the device…so next step I guess is the find and try the URL

Deleted image.


#13

When I click on image settings…this is what I get

Deleted image.


#14

Great!
In your case you have it in the first picture

port is 554.
Install NCS also and make sure it works with this url locally or use the tab for ONVIF Source that should detect this. OR use this on the regular computer and change LAN to the WAN address. Make sure to port forward port 554 on the router.


#15

Hi,
How are things going?
Nice to have report back in the forum to support others.
Thanks,
Henrik


#16

Im still working on it…I tried what you suggested and so far no go…when I put the WAN ip in NCS with the command line…still not getting sound…will continue workiing on it… (right now a bit distracted with business matters) but will give feedback


#17

Fine. I can connect also from here with template and custom url. I have sound also, but I have turn up the volume to max to hear something. The noise in the system will be loud. So somewhere in the camera config there is a volume control or something. I can hear the person typing on the keyboard, but he is not talking that much right now :slight_smile:
.Henrik


#18

I logged on to the camera directly with Foscam software and cannot see any settings for audio…other than to enable the ONVIF which I did.


#19

Actually, I have sound, but I have turn up the volume to max to hear anything. The noise in the system will be loud. I can hear the person typing on the keyboard, but he is not talking that much right now :slight_smile: The microphone might need some adjustments?
.Henrik


#20

Sounds great…can you send me the custom url and some simple instructions let me give it a try and have some music playing here to test the sound…