App reset and push notifications not working?


#1

Hio,

Having searched this forum for my issue I found only one post that was not helpful.
So I hope I can get some help here.

Phone: Galaxy S8
Androidv: 7.0.1
App: Latest from Play store

Netcam Studio Server: V1.6.1.0 on Windows 10, 64-bit

Installation procedure:

  • Running setup
  • Adding my own account and removing admin
  • Opening router ports 8100 and 8124
  • Installing app and connecting with my phone

Whenever I enter the Netcam studio app I must always manually “connect” to my server… I guess this stops notifications from working?
Since I dont receive any and my server outputs the error below the GIF

Have I missed something crucial? Running a free account at the moment

Notifications error:

Error details:
Error while sending Push Notifications to 1 device(s).
Exception Detail:Det fanns inte någon slutpunkt som lyssnade på https://my.netc.am:9100/Soap/ som kunde acceptera meddelandet. Detta beror ofta på en felaktig adress eller SOAP-åtgärd. Du hittar mer information i det interna undantaget (i förekommande fall).

Google translate to english for convenience :
Error while sending Push Notifications to 1 device (s).
Exception Detail: There was no endpoint listed on https://my.netc.am:9100/Soap/ who could accept the message. This is often due to an incorrect address or SOAP action. You will find more information in the internal exception (if applicable).


#2

Well for some reason it seems to work now :slight_smile:


#3

Hi there,
Svenska går utmärkt :slight_smile:
-only port 8100 in necessary to forward in the router for the web client and mobile app.
-good, I used my magic on the push server :slight_smile:

Thanks,
henrik


#4

Bra att veta :slight_smile:

So I dont need port 8120 or 8124 on router for push to work?

:slight_smile:


#5

Nope. Only port 8100 for NCS web client and NCS mobile app if on WAN public network. If you want to use NCS Windows Client on WAN you need to forward ports 8100, 8120 and 8124.
-henrik


#6

@Henrik may I ask, will there be an auto connect feature for servers when you open the app, so I don’t have to hit that connect button all the time?
I will never run more than one server :slight_smile:


#7

The reason for not having auto connect is security to prevent unauthorized people to get access to surveillance material. However, you are not the only one asking for auto connect so it is on the suggestion list. We have to check if it is possible to solve this with some security.
-Henrik


#8

Won’t be any difference security wise from now? It’s just a press away without any security as it is now :slight_smile:


#9

Yes, you are correct :wink: I was thinking about the web client. Maybe a checkbox for autologin would be possible in the server config.