Brickcom OB-200Np support


#1

Hello

I haven’t been able to find this IP camera in the list. I am not familiar with it’s APIs and I have not tried to get it working in different software, however I did get it working in Netcam Studio by using the profile for the OB-131Ap and changing the stream to MJPEG, but I am limited to MJPEG and I have no ability to Zoom.

I am able to provide internet access to the camera on request.


#2

Hi again!
What is wrong with all the cams that we support ;). ;). Well this seems to be an easy one with a good documentation which I recommend to download.
The cam is not ONVIF compliant so you need to add it using the tab Custom URL. Set the stream type to rtsp_tcp and use this URL that I got from the manual
rtsp://username:password@ipnumber:554(channel1
It seems that the cam can deliver 3 stream so the channel number can maybe be 1 to 3. You can set that in the configuration of the camera. Maybe one channels is for mpeg4. In that case set stream type to mpeg4. Probably will channel1 give you the highest resolution.
The zoom function cannot be reached from the URL. It must be implemented in a template and trying to figure out the commands we need to have full access to the camera.
-Henrik


#3

Hello
Thanks for the info. However I see mention of ONVIF in the options menu of the camera. Is it’s use of ONVIF not compliant (if that is what you meant)?


#4

OK, good! I did not see that, sorry… Enable ONVIF, which seems to be default, and you should be able to add the cam using the onvif tab. I do not know what WS-security is. The tab video and audio might also be of interest. If the onvif works you should probably see the URL that I wrote under the Custom URL tab.
-Henrik


#5

Just to let anybody else who needs to know, the only important setting that needs to be set is Asynchronization, next to GetStreamUriResponse


#6

With version 1.3.9.0, you also have to do this setting like so:

Otherwise you will get no feed.


#7

This setting is more about to config the h.264 bitstream to work with the ffmpeg codec. Set this from NCS is probably not doable, but I check.
Thanks,
Henrik