Cams not showing

netcamstudio

#1

My company just purchased the 4 use license of Netcam Studio as we were using WebcamXP for a long time but became buggy. We have a new wordpress website and embedded the the video code provided with the < > to the website and what appeared is the size of the screen but with a small black x. There is one comment from support saying there has been a ticket submitted for the issue with Wordpress and in the meantime to create a blank .html file which I did and am still getting the size of the feed but it’s blank with a small black x. The new Wordpress build is temporarily being hosted at 205.134.238.251/~houndaroundresor/


#2

Hi David and welcome to the forum!
Nice website you have.
I checked the html code of the the webcam page and there are some things that you need to look into.
The URL for the cams looks like this
http://127.0.0.1:8100/Mjpeg/0?authToken=c13f2203-ad33-4f11-95e7-35a4d247ceb9

  • the IP number must be for the computer that runs NCS. Here it seems that NCS runs on the same computer as the web server. 127.0.0.1 is also called localhost and is the same computer as the web server is running on. If it is not the same computer change that IP to the IP of the NCS computer.
  • Mjpeg/0 you use the same camera in all your URL´s.
  • when you generate the html code in NCS you cannot use the admin account because the token will change at a reboot/restart of the NCS server. Create a separate account for this which only have access to the cameras that you use on the web site.
  • Wordpress. For a couple of months ago I was looking into this since another user also used Wordpress. At that time it turned out to be a problem with Wordpress that do not allow to embed code for streaming. I am not an expert of Wordpress, but a plugin or some setting was necessary. You can check this by creating a simple webpage (not in WP) and embed the html code for the cams and upload that to the web server. Then call on that page like 205.134.238.251/~webcamtest.html or something like that depending on the library structure. For the other user that worked fine.
  • a work around Wordpress might be to crate a web page outside of Wordpress and when you click on Webcams you are directed to that page outside of WP that opens in a new tab or window.

This is all what I have for now. Good luck,
Henrik


#3

Where do I change the IP?


#4

Hi,
To make this work there are several steps that you need to do. When everything is done the IP number you use instead of 127.0.0.1 is an IP number that point to your computer. Follow this guide and it should work.


Good luck,
Henrik


#5

It turns out one computer has both netcam studios and manages the IP cameras so of I understand correctly 127.0.0.1 should be right. Furthermore, it works if you go to…

I can broadcast it here with the user log in credentials (see below) so why not via the code for my site?

http://livehoundcam.dlinkddns.com:8100/#source/0

user: user
password: password

Just not able to embed on the site


#6

I found here - How can I change web server hostname

I needed to change the localhost address in the code of the camera’s to the static IP. Did, done, works. Thanks!


#7

Excellent! Now we know it works in WordPress also.
The site looks really fine with your fury friends :slight_smile: ).
-Henrik


#8

I thought it worked replacing the IP but it’s not…

http://205.134.238.251/~houndaroundresor/webcams.html


#9

not in wp or the static html page


#10

ftp upload settings is red


#11

Changed everything back. Works. Seems wp doesn’t like embedded video


#12

WP works from my tablet. Weird.

http://205.134.238.251/~houndaroundresor/webcam/


#13

the feed is choppy. how can I make it more smooth?


#14

Hi David,
First, this is an open forum for learning from each other so I would very much like you to confirm if this works in WordPress or not?
Second, the choppiness. Most likely due to limitation in speed of the Internet connection. Video use a lot of bandwidth.

If the cams are connected to the LAN with wifi, check the signal strengths. Check also the bandwidth to your internet provider.

Check this setting

Uncheck High Q. Also test Single and Mutli view refresh rate if that will be better. To stream 4 cams live you probably need more bandwidth for the Internet connection. Alternative is to slow down your dogs ;).

Also, I forgot. Four cams in high resolution usually takes a lot of CPU power depending on the processor. What is the CPU load of your computer?

-Henrik


#15

Yes, sorry. I had issues that was entirely my fault messing around with the code. It did work then I screwed something up but realized my mistake and fixed it. I am a Wordpress Developer and got it to work at the link below. What you need to do is apply the given < > code found provided by the NCS program and when in a wordpress page or post, DO NOT apply the code to the “visual” tab of the wyswyg text editor but put the code in the text tab. Also if you see the link below I was able to also use the static html page for larger viewing.

http://205.134.238.251/~houndaroundresor/webcam/

Hope this helps


#16

Excellent, thanks a lot. Precisely the info that is so valuable for the community!
-Henrik


#17

No problem. So what do you think the single and multi FPS should be set at? The CPU load is currently and has been at or around a whopping 98 percent with NCS bouncing around 65 to 75 percent. Ouch.


#18

Also, what should I have the decoding settings in NCS at? Currently it’s at the default at Software_Internal. Should I use VLC?


#20

That CPU load is way to high. You need to do some testing to find out what is best with the existing internet connection and what is acceptable for the web site.

  • decrease the resolution of the cams.
  • start with only one camera connected to NCS and learn how the chain from camera to video on the web site is affected.
  • In the recording settings you need to experiment with video quality and Images per second.Images per second usually affects the CPU load mostly.
  • decoding settings should be Software_Internal. You can change to Hardware_dxva2, but it depends on what hardware you have in the computer. Most likely it will not change anything.

-Henrik


#21

So I dont screw up settings I did before, how do I exactly decrease the res in NCS? I am messing around with the recording and will take your advice about the decoding.