Cannot Play MP4 Video


#1

I tried to play a .mp4 video file in the recording folder and it has audio, no video. So I downloaded VLC but same issue.

I read in the forum that this could be caused by changed video settings, but I don’t know what settings to use as the “good defaults”. on the recording tab in settings, I had adjusted the FPS to 4, but I don’t recall the original value, or what settings I should put back in place.


#2

Hi there!
Yes, VLC is the player we use as default.
To find out what is going on do this. In NCS when you have video and audio showing from a camera do a manual recording from that camera either by right-click the mouse and then record or by clicking the record icon on the bottom of the camera video.
Then go to Library in NCS and click on that video. VLC will start and show the recorded video. Or go to the Library folder and play that video. I assume that you have video and audio?
When is it that you don’t have video? Do you run the camera in motion detection? Are all videos like that, audio but no video, or is it just some of them?
-Henrik


#3

I think it was related to the framerate setting I had messed with. I set it back and now produced videos (all I’ve been working with so far are short clips as the result of motion detection). I set the frames per second back to 30, and that seems now the files show video content now (in addition to the sound).

I’m not sure why turning it down did that, although the files themselves didn’t really get too much larger (they’re pretty short, only 10 seconds when it detects motion) so maybe I was just way too aggressive when I turned it down to 2 FPS.


#4

When a video encodes the mathematical algorithm must have enough data to work with so a combination of low FPS and a short video will not work. So you found the reason :slight_smile:
-Henrik