Connection Failed


#1

Hello,

I’m trying to add this IPCamera on Netcam Studio X via ONVIF : https://www.amazon.fr/gp/product/B076HN99FC/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

The camera is found on the right IP adress. I set creditentials, but after I have an error “Connection failed”.

I don’t understand why, Creditentials works perfectly :frowning:

In log, I have this error : Connection with Sender not Authorized has been lost. Will try to reconnecter un 1000ms…

Thank you


#2

Hi,
When you have this connection failed go back to camera config. and tab Custom URL. Switch between rtsp_tcp and rtsp_udp. That usually helps.
Try also to use a PTZ profile since the camera is PTZ.
/Henrik


#3

Hello Henrik,

Thank you for your answer, I switched between rtsp_tcp and rtsp_udp but nothing change. Is it normal this message error "Sender not Authorized ?

I also tested all 4 PTZ profiles :frowning:


2018-11-27%2015_07_19-Window

Thank you


#4

:slightly_smiling_face: well well. This was a new one.
Usually in the Address field you get an URL like rtsp://xxxxxx and the red screen, but here you just get this “Sender not Authorized” message?
I assumed that you used a rtsp profile? If jpeg selected stream type must be jpeg. But, stay with rtsp.

It´s clear that username/password is incorrect. I have two suggestions:
1.some cameras have a more advance security for the rtsp login. Login to the camera configuration. Find something about rtsp login. Usually it is called Basic and “higher level” or something like that. Use Basic. Test again.
2.I have a couple of cameras with a bug in the firmware. When I change login from default to custom I can use the customized username/password to login to the camera. But, when I use the rtsp://xxxxxxx I must use the default username and password. So go back to the default logins and use that for the ONVIF process.

-Henrik


#5

Thank you for your answer.

Yes I have just this error message and “connection failed” when I close the config window.

  1. I Can’t choose an option like this in Wansview iOS App, I can just add users (administrator, operator, spectator), I used Administrator.
  2. I reset the camera, I used default login / password… doesn’t work. I still have “Sender not Authorized”.

In the manual, it’s written if I want to use with a third software, I have to use :

RTSP Stream: rtsp://IP:rtsp.port/live/ch0 (RTSP Port by default : 554)
MJPEG Stream : http://ip:port/pjpeg/stream.cgi?chn=0
Snapshot: ip:port/mjpeg/snap.cgi?chn=0

If it can help you :confused:


#6

Aha, very good information.

When adding the camera go to tab for Custom URL.
Set stream type to rtsp_tcp
Set Address to
rtsp://username:password@cameraIP:554/live/ch0
or
set stream type to MJPEG
URL is http://username:password@cameraIP/mjpeg/stream.cgi?chn=0
This will only give you video and audio.

However, if you also want PZT I suggest the following for test.
Do the same procedure as above with the ONVIF and select Profile 1 - RTSP
Save this. No you get this red screen.
Go back to the tab for Custom URL.
Now you should have this Sender not Authorized.
Delete that and enter
rtsp://username:password@cameraIP:554/live/ch0
Save this. Now it is interesting what you get.

Test also this if the above fails
image

Mow I am out of ideas :slight_smile:


#7

Yeeeeeees !

With the custom URL 'rtsp://username:password@192.168.1.182:554/live/ch0), it’s working !

The PTZ seems not work (I click on arrows but nothing happens), but thank you again.