Digitus DN-16051 and DN-16055 via network are really supported?


#1

Hello,
I’m testing webcamXP (the free edition) with 2 Digitus’s IP Cam (DN-16051 and DN-16055) because I read they are supported. The problem is that I don’t see anything. The Test on the “Network Camera Setup Wizard” returns “HTTP/1.0 200 OK”. In the Information window, after the connection, I see the row “GET >> http://xxx.yyy.zzz.nnn/live/mjpeg >> HTTP/1.0 404 Not Found” (where xxx.yyy.zzz.nnn is the CAM’s IP address). Are there anyone that could help me to setup correctly these IP cameras with WebcamXP software?
Really any thanks in advance
Ciao
Michele


#2

Hi Michele,
First I would like you to switch to Netcam Studio (next generation of webcamXP/7) since that is much more up-to-date program and more easy to work with for IP cams. NCS also support Digitus and the models you have. You can download NCS here http://netcamstudio.com/ Install NCS and add these cameras. If still problems, please come back.

I have been searching for information about these cams, but I do not find that much for the moment. Start with NCS and come back if/when problems ;).
-Henrik


#3

Hi Henrik,
really many thanks for your post.
I downloaded the x64 version of Necam Studio and I installed .NET Framework 4.6.1 first. After the installation of Netcam Studio X I ran the server to add the sources but I had some problems. The test camera connection returns errors to all operations: "Video failed with error: Server remote error : (404) not found. Audio failed with error: Not tested. I tried to setup the “Stream type” in “Custom URL” section without any positive results. I tried to add Digitus’s DN-16051 and DN-16055. I connected the CAMs via LAN.
Thanks


#4

Hi again!
I have some more info about this. From your posts I think the problem is the URL to the cameras. Both webcam and NCS find the cams, but the URL to get the video and audio is not correct. Do both cameras have video and audio or is it only video?
In NCS connect using Custom URL.
Set Stream type to MJPEG
Use following URL http://username:password@ipnumber/live/mjpeg

What happens? I think that it connects to the camera, but you will not get a video?

Stay with NCS since that is more easy to work with and I will check this /live/mjpeg which I think is the problem.

I will be back :wink: .
-Henrik

EDIT:
Test this in NCS for both cameras in Custom URL
Set Stream type to MJPEG
Use following URL http://username:password@ipnumber/cgi/mjpg/mjpg.cgi

Connect the DN-16055 with PTZ using the template for that camera. Video/audio will probably not work, but does PTZ work?


#5

I Henrik,
really many thanks for your support. I’m sorry for my late to reply you.
I tried what you have suggested me, but It happens nothing.
In “Network Camera” I set the server IP/Host, the brand and model and in “Video Preset” I set “MJPEG”; in the “Custom URL”, I set what you suggested me. I tried with and without PTR. In the logs I find errors "Exception using http://admin:admin@IP_CAMERA/cgi/mjpg/mjpg.cgi
Exception Detail:Errore del server remoto: (500) Errore interno del server."
For your reference, the only software that is able to show something is iSpy, but id doesn’t manage the Digitus DN-16055 IP-CAM. Of course the factory’s software works in right way but this software is “closed” and for example I cannot see 2 cameras (or more) in the same moment.
This means that I’m in your hands to try to get the video from the 2 IP-CAMs
Another thing. The DN-16051 is online also with VLAN by http://admin:admin@IP_CAMERA_16051:80/cgi-bin/guest/Video.cgi?media=JPEG
If I use the same command (with the IP address of DN-16055 of course), VLAN returns an error “The input cannot be opened:
VLC is not able to open MRL ‘http://admin:admin@IP_CAMERA_DN16055:80/cgi-bin/guest/Video.cgi?media=JPEG’. Control the log for the details.”

Thanks again
Ciao!
Michele


#6

Hi Michele,

If it works in iSpy it can of cause work in NCS. It is just to find the correct URL. Sometimes it is easy and sometimes it takes some testing. So next test ;).

I received information about this from the Digitus support.

Use ONLY Custom URL when you add the cameras. Do not use Network camera!

DN-16055:
http://username:password@IP:PORT/cgi-bin/guest/Video.cgi?media=JPEG
http://username:password@IP:PORT/cgi-bin/guest/Video.cgi?media=MJPEG
rtsp://username:password@IP:PORT/live/mpeg4
rtsp://username:password@IP:PORT/live/mjpeg

Set stream type to jpeg, mjpeg or mpeg4 depending on what URL you use.
For http set PORT to 80
For rtsp set PORT to 554

DN-16051:
rtsp://username:password@IP:PORT/live/mpeg4
rtsp://username:password@IP:PORT/live/mjpeg

Set stream type to mpeg4 or mjpeg depending on the URL.
Set PORT to 554

If this still do not work I need to have access to the cameras so I can test different URLs from my system or if I can get access to your computer with TeamViewer. If this will be necessary you can come back here and I will send you a PM where we can exchange details.

Good luck,
Henrik


#7

THANKS!!! now it works!!
The informations that I needed was 2:
Use ONLY Custom URL when you add the cameras. Do not use Network camera!
for DN-16055 I used http://username:password@IP:80/cgi-bin/guest/Video.cgi?media=MJPEG
for DN-16051 I used rtsp://username:password@IP:554/live/mpeg4

Really many thanks again!!!
Ciaooo!


#8

Hi,
Excellent and thanks for reporting back! Important information to other users.
Good luck,
Henrik


#9

Hi Henrik,
really many thanks to you again. There is only one problem. The DN-16055 has the pan & tilt. How can I manage them? without the setups in the network camera section, these functions are disabled.
Thanks again.
Michele


#10

He he, I suspected that ;).
Using the Custom URL do only get the video/audio. Problem is that PTZ and video/audio use different communication protocols. To make both PTZ and video/audio work these two must be combined in a predefined template.

The old template for DN-16055 included both PTZ and video/audio. I have to update that template with the correct URL for video(audio. Before I do that I need to know if the PTZ worked with that template? I would appreciate if you can test that for me.

A new version of NCS is on its way out and maybe I can the corrected template in that release.

-Henrik


#11

Hi Henrik,
I can test everything (I’m already testing). No problems. Please take note that I’m not an expert about video-sourvellance.
(I’m a PC technician for hw & sw and o.s systemist). For example, I woud like that the IP CAM (DN-16055) follows the movements of any objects/people that activate it by motion-detection.
About your question I don’t understand exactly what you mean. If I use any templates, the DN-16055 apparently doesn’t works because NCS doesn’t shows the video and the camera doesn’t makes any movements. It is the reason because I wrote you. Now NCS shows and records from 2 Digitus cameras and it is ok, also motion detection is OK, but, I repeat, on DN-16055 I’m not able to setup the PTZ. Thanks.
Ciao!


#12

Hi Michele,
I think you are doing great! No problems at all!

I need to know if the PTZ commands are correct. So I would appreciate if you can do this:
-in NCS delete the camera DN-16055 using the Custom URL
-add the same camera, but use the template like this:

-When you click on Test connection you will get 2 red icons. That is fine.
-Click on Save.
-Now you will have a gray or white image telling you that there is no connection.
-I am not sure about this, but can you see the PTZ controls?
-If you can see them test them and see if the camera moves. If the camera moves you can stop here and report back.

-If you cannot see the the PTZ control, please add the camera in WebcamXP or 7 and test the PTZ controls and see if the camera moves.

By the way, interesting project with tracking the moving object. That is not in NCS, but it is a really good idea for the future!

Thanks,
Henrik


#13

Hi Henrik,
when I set the “Network Camera” fields, I’m able to check/uncheck (or tick/untick) the PTZ too.
The problem now is: Where I can see the PTZ controls? In “Configure Features” I don’t see nothing about it.
Ok, following the object-movements isn’t an actual feature. Don’t worry. I would choice the pre-set Pan&Tilt that I configured in the CAM; or I would set some of them.
Thanks
Michele


#14

Hi Michele,
Can you give me access to DN-16055 camera? I think it would make life easier for both of us ;). Please, report back here and if OK I send you a PM where detailed information can be exchanged.
Thanks
Henrik


#15

Yes. Of course. Please send me a PM and I’ll reply you the public IP and the port number to manage it.
Thanks


#16

Hi Michele,
Now are the PTZ commands (up, down, left, right and zoom) together with the URL for video implemented in the xml file. Do you want it for WebcamXP or Netcam Studio? To make it work in WebcamXP will go faster, but it is up to you. You can also close the port since I am done with the camera.
Thanks,
Henrik


#17

Hi Henrik,
it is the same. I’m looking for a software, like yours, that must be “user-friendly” and that can supports all kinds of IP cameras. Thank you very much for your support. Please let me know what I have to do now to get the PTZ commands (I suppose that I have to download an upgrade).
The TCP ports are being to be closed. Thanks again!
Ciao!


#18

Hi Henrik,
after a long time I just re-test your software. I downloaded and installed the new version (Netcam Studio X (x64) v 1.5.1.0.
Now the DN-16055 template has PTZ controls, but Zoom is the only command that works and the PTZ control panel doesn’t have the preset position buttons.
The new graphic design is really cool.
Ciao!
Michele


#19

Hi Michele,
Since I haven’t heard from you I was hoping that it all worked, but how wrong was I :cry: Well, that’s a bummer since we put a lot of time in this. I have to check this!
But, I am glad you like the new graphic design! :slight_smile:
-Henrik

EDIT
Of cause it took me 5 sec. to find this since Zoom works. A missing PTZ that connects the command to the button, sorry!
Just got information the NCS do not support presets.
I will forward tte changes in the template so it can be in the upcoming release.


#20

Hi Henrik,
don’t worry even if, in true, I replied to your last e-mail. I thought you was busy. Me too… :wink:
For your reference, I found the DN-16055 PTZ commands are the same of AVTech AVx 322.
Ciao!