Help Connecting vStarCam C29s


#1

Trying to get this Vstarcam C29s to work with Netcam Stuido X. I was able to get it to show live video using the preset for vstarcam F6836W, Put it only has MJPEG 640x480 or 320x240. I would really would like to get the full 1080P this cam has and also get audio. Please help if you can, I have been reading post and trying ONVIF with no luck, also custom URL.


#2

Can you give me a link to information about the camera.
If it says it support ONVIF then it should be there when you search for it under the tab for ONVIF.
What URL did you use in Custom URL?
Quite often these cameras also work with preset for Foscam FI8919W or FI8918W. Set rtsp port to 10554.
-Henrik


#3

Camera Info: http://www.eye4.so/FAQ/c29s
the first thing that worked was the preset for vstarcam F6836W in NCS
But only in mjpeg 640x480.
I downloaded the program ONVIF Device Manager, and found so needed info about the camera.
I was able to get a custom URL to work but only over RTSP_TCP.
rtsp://admin:password@IP:10544/tcp/av0_0
Just replace PASSWORD and IP with your own info.
I get the resolution I wanted and interment sound, still can’t find the motion controls in NCS.
Also I am not able to login to the camera in IE.


#4

So far so good then. Problem is that audio/video use rtsp and ptz use http. So entering the rtsp will never get you ptz. To get all, the protocols need to be combined in a predefined template. This is a drag so therefore the manufacturers started to develop a standard for devices like IP camera so it should be easy to connect to them from softwares like NCS. Problems is again that it is standard within quotation marks. So ONVIF is the only way to make it all work.
Since you are working with ODM and got the rtsp string you should also be able to find the http onvif URL that should get the different profiles. Go to ODM again and login to the camera and go to
image
At the red arrow you should have the magic URL. Copy that URL and paste it into where the red arrow is pointing below in NCS
image

Add username and password and click on Get Profiles. If everything is as I hope you will now have some ONVIF Profiles to select and then select PTZ mode. I recommend to use static IP to make it more stable.

I keep my fingers crossed!!
-Henrik


#5

Tried your advice but I did not get good results. The profiles it got where
Profile_000 JPEG (1920x1280)
Profile_000 RTSP_UDP (1920x1280)
Profile_001 JPEG (1920x1280)
Profile_001 RTSP_UDP (1920x1280)
The jpeg profiles would connect but only displayed a 320x240 feed
the RTSP_UDP profiles would not connect.
Thanks for your help tonight but I’m done for the night, I will try again tomorrow to play with it.


#6

Excellent, this was much better than I expected. Some things:
1.ONVIF URL
Please post the ONVIF URL here to help the next user.
2.Resolution
Go into the configuration of the camera and setup the resolutions for the profiles. Most likely they are set to 320x240.
3.RTSP
Select Profile_0 and Save. No you have the blue screen with No Connection. Go back, but now go to the tab for Custom URL. There you have Stream type and Address. Change Stream Type from rtsp_tcp to rtsp_udp or vice versa. Save. Now you should have a connection, I hope.
4.VLC
If there is still no connection copy the Address/URL into VLC and test if that works.

-Henrik


#7

ONVIF URL http://IP:10080/onvif/device_service
Just replace IP with your own info.
camera config is not accessible in IE and very limited in EYE4.
the only resolution config I have seen is in ODM.


#8

My 3 and 4 above?
If you go to the link that you gave you have web client user guide in which you can change many parameters.
Click on Apps download and you will have IP camera finder for Windows and also a plugin for IE. Test them.


#9

Finely got in to camera config, had to use Chrome, Microsoft Edge would not let me login.
There is NO settings for the profiles. But I did find a working RTSP_UDP URL so here it is hope it helps someone
rtsp://admin:PASSWORD@IP:10544/udp/av0_0
Just replace PASSWORD and IP with your own info.


#10

@Henrik I just wanted to thank you for all your help. Today I install a second camera and it was a breeze. I also registered my NCS and it’s all because of great people like you who help others.


#11

Hi,
Thanks a lot for the kind words! It can be a little bit tricky sometimes to make it work, but I am happy it was successful in the end. Thanks also for registering. That help us continue.
You know where to find me :slight_smile:
Henrik