Here is an odd one - FPS reducing with time


#21

Hi Henrik,

Switched to Software_vlc but didn’t notice any difference, same FPS drops.

I will keep trying to fix it.

Thanks


#22

Changed to software_vlc and it didn’t seem to make a difference.


#23

Ok guys. For me in all my systems changing to software_vlc the fps will not drop and in my biggest production system fps will go up (don’t drop from original fps) for rtsp connections. I have tested this several times with the same result.
First, after saving software_vlc you need to restart.
Second, when changed to software_vlc and restarted and put the cameras in motion detection do you get the yellow frame around the video image or not?
I assume that you run NCS ver 170.
-Henrik


#24

Yes, I get yellow frames, but it still drops off on the fps.
Just now, all 3 were sitting with yellow frames at ~15fps and I restarted the service and they all jumped back to ~30.

One other interesting thing I found was that while testing another open source program, with 2 streams coming from the same camera and going to each program on the same computer, the FPS dropped back on NCS but stayed up at ~30 on the other program. This tells me that it’s not likely the camera or the computer that’s the issue.

By the way, I really appreciate all the work you’re doing to try to figure this one out.


#25

Also, yes, NCS ver 170


#26

Thanks, but it’s my job trying to figure this out so I am happy with all help I can get!
Interesting is yellow frames and drops with the service. I get no yellow frames no drops running ncs x. Can you switch and I will switch also and we’ll see what’s happening.
I am sorry if I am stubborn here, but are you really sure that you switched to software_vlc?


#27

I think the yellow frame only means that it has motion detection enabled. (Mine is)
Yes, I am absolutely sure I switched to software_vlc:

  • Select Software_VLC in decoding settings - save
  • Restart Netcam Studio service

#28

OK, fine. Yes, it´s just to indicate that motion detection is running, but it’s also an overlay which I do not have for some reason.


#29

Just noticed this thread. Having the same issue. Can confirm similar settings, but haven’t tried the software_vlc. I actually just set my cameras (via their own firmware) to reboot every morning, but they’re always back down to ~15 fps by mid day. Any interruption of the stream seems to reset it back to 30fps so I wasn’t convinced NCS was the issue.