How can I make timelapse stop and restart every X amount of time?


#1

I’m using timelapse, and it works fine but the issue I’m having is this:

Is continuously records nonstop, for days or weeks, and there doesn’t seem to be a way to limit that time. For example, stop recording every 12 hours and start a new timelapse. The reason I need this is because when I manually stop the timelapse myself, my CPU goes up to 100% and it will stay there indefinitely (ffmpeg.exe), I think saving/converting the timelapse into a video. I could get around this by stopping and starting the timelapse myself, but manual labour is not the point of software.

When I close ffmpeg.exe to stop CPU usage, then the timelapse is totally lost. But while it is running, I can view the entire timelapse nicely. What is the purpose of it anyways?

And more importantly, how can I set a limit to timelapse files?


#2

You can use Timelaps in Scheduler. In Settings - Recordings you can set the length of a file. The behavior of ffmpeg seems not normal so it might be another problem as well.


#3

Thanks Henrik. Here are my settings and as you can see, the time lapse file still goes on indefinitely.


#4

That is the length of each recording before it creates a new file. In Scheduler, right-click over the camera image, you set between which hours it should record.


#5

Yes I want a new file every 6 hours, however it does not create a new file - it goes on forever. Sorry, I am not trying to be obtuse, but I don’t think I get it. I also just don’t understand the scheduler. I don’t want to schedule, I want 24/7 timelapse recording with files at 6 hours each.


#6

No problems. Not always easy to get it right. If I understand you description correct now I would do this.
image
This will take a picture every 30 seconds. The picture will show during 1 second in the movie.
I set Scheduler like this because if the computer stops and start again and NCS starts automatically with this setting Timelaps starts automatically and runs 24/7.


With your setting above
image
each file will be 6h long and then a new files start 24/7. Recording is at 25 FPS.
This will be very large files. Is really 25 FPS necessary with still images.

I have not tested this myself.
-Henrik


#7

Ok I have done those settings, except I did 1 second for frame interval and 40 ms for frame duration. This should still work, correct?

Also, I setup the scheduler, however restarting the program reverses the scheduler setting back to no action.

I will run overnight to see if the files renew every 6 hrs.


#8

Don’t forget to Save!


#9

Okay after much more testing, it really seems to me that the settings don’t affect timelapse image quality, for example setting lower than 25 fps does nothing. Also, the 6 hr file limit doesn’t affect timelapse.

My problem is this:

  1. Timelapse videos keep recording in a single file forever. They never start new or overwrite old ones.
  2. When I manually stop/start the timelapses, the video is converted from .avi to .mp4 using ffmpeg.exe process, and it takes a very very long time and I’m unable to use netcam while this is happening. I think it wouldn’t be a problem if the timelapse file was only 6 hrs, but I restart like every two days or so and the files are big.
  3. My PC runs out of space if I don’t manually go in and restart everything and delete older files. I think the settings in the “library” tab have no effect on timelapse either.
  4. Hitting the checkmark in schedulers (save) does not save the setting for me.

This problem is in 3 different PCs. I’m not sure what else to try.


#10

Why don´t you use continuous recording?
2.a lot of data to convert. Need better hardware. ffmpeg use available resources for the conversion to go as quickly as possible.
3.have effect on the ready and stored files.
4.the setting is stored directly when changed. No need to click on check mark. I have to check if that is according plan or not, thanks.

-Henrik

EDIT: Tested to run the Scheduler and it works fine and start/stopTimelaps and then converts avi to mp4. After the conversion the mp4 file is part of the Library settings to be deleted after a certain amount of time.


#11

You know Henrik last software I used I had bad experience recording regular for long duration, but actually after some testing I would much prefer to use continuous recording. It doesn’t take up as much space as I thought.

But I have hopefully a simple issue to solve:

Recorded video starts smooth, but jumps down to looks like 1 fps per second. If I enable multi-threaded options the video stays smooth, however I can only have 2 cameras recording at once with 90% CPU usage (i7 3770k OCd)

What can I do to solve this (and should I make a new thread?)

Thanks so much for your great customer service Henrik


#12

Thanks!
The processor is a very good one so that should be no problems for 2 cameras. Multi-threading should not be necessary and go down to 1 fps is really bad so it gotta be something else.
What cameras do you have and how are they connected; template, onvif or custom URL? What resolution do you use?

I would recommend to go back to default values in NCS. Easiest way is to C:\ProgramData\Moonware\Netcam Studio\Server and delete the file server.config and start NCS again. However, remember how you connected the cameras since you need to do that again.

-Henrik


#13

Alright I got them all “good enough” for now. Still have issues with the smoothness of the recordings but I’ll continue to mess around. I had most issues with my amcrest 2k camera. I lowered the resolution down to 2304x1296 and raised the bit rate to 8192, and that seemed to help a lot. But it still seems as though the recordings are slower in FPS when compared to live view. And a lot fo stuttering and lag in the videos (e.g video will freeze for one second, and then the car will continue on faster than it should to “catch up” to real time)

But as I said they seem to be recording well enough. I’ll see how the videos are in the morning


#14

Henrik this will be my last post in this thread for this issue, I’ll be making a new thread if I can’t resolve this myself, but I just wanted to know: should I expect smooth video, without jumps or lag, if my settings are configured properly? Or are such things common even with the right settings? All my cameras are wired so I feel like if done right I could have really good video quality.

Also, for my i7 3770k, can you approximate how much CPU it should be using? What is the typical usage? It’s maxed out with 6 cameras which I think is causing some of the issues. I plan to add up to 16 at some point.


#15

I you answer my questions and do as I recommend I might help you further. If you want to mess around yourself it is fine, but you cannot expect me to help with that.