Motion detection doesn't work during day time


#1

I am running NCS as a service which triggers events on my automation system when motion is detected, but it only seems to work about 1 hr before sunset. I tried turning motion on every hour of every day in scheduler, but that did not work. Any Ideas?


#2

What an idiot I am, I had the detection zones reversed. It’s backwards from other software that I have used. Normally you need to highlight what you don’t want to motion detect instead of what you do.


#3

You are not the only idiot ;). Several including myself discovered that the hard way also. ;).
-Henrik


#4

I actually had it correct the first time, highlight what you don’t want to detect. I am still having problems with motion detection during the day. I had two packages delivered during the day today and I came home about 6pm. None of this set off the motion detector, but when I went on the front porch after it was dark motion detection worked. I was out of town since yesterday afternoon so my computer didn’t have any activity on it overnight and all day. It seems NCS is falling asleep after a certain amount of time and not waking up until I log onto the computer (I mostly log on at night after I get home from work). I also see “Video Source Stopped due to inactivity” in the event logs. Is there a setting that I can change so NCS doesn’t stop do to inactivity especially when I have the motion detection turned on?


#5

Hi! If you run NCS as a service it is designed to not make the computer fall a sleep since you want to monitor 24/7. If you run NCS on a laptop the computer sometimes override that so check the settings. Also I am not sure what happens when you logout. “Video source stopped due to inactivity” happens when NCS do not use that camera for anything to save energy. Have you scheduled the motion detection to 24/7? Also, check in the connection (wifi?) is lost.
-Henrik


#6

Same thing today, only detected motion after I connected with the android app from my phone. My computer is a desktop running Domoticz server (and NCS server) so it never sleeps. I figured out the camera it’s turning off for in-activity is not the source I am trying to troubleshoot so it’s not that. I looked again at the scheduler an it looks like “no action” was on even though I scheduled motion on 24/7. Once I highlighted Motion, the event log looks like this:

at least is states wakeup now, but not sure why so many entries if “already connected”? I’ll see what happens tomorrow.


#7

From the picture above it seem that something in not correct and interfering with how NCS works. This is how it should look like when motion detection is running:

The video image should have a yellow frame with a signal level bar that indicates the motion level and goes red when motion is triggered. The scheduler is the picture to the right.

What windows OS are you running and NCS must have .net framework 4.5.2 or newer installed to work.


#8

Thanks again Henrik! My HA computer is Windows 10 and they automatically install .net framework 4.6.1. According to every website I looked at, 4.6.1 only causes issues, it probably only works with windows crapware. I tried to follow the directions on this website to remove it, but I did not have the KB update, http://www.expta.com/2016/02/how-to-uninstall-net-framework-461.html I tried the removal tool and verification tool, but the verification tool still shows that I have 4.6.1 on my computer even after several attempts to remove it. This forum http://www.tenforums.com/software-apps/5385-how-uninstall-net-framework-4-6-a.html shows how to disable it in program features. I tried that and NCS works without having to log on. Now if I can tweak the settings so the rabbits, cats and bugs don’t set off motion detection!

Another thing that turning off .net framework 4.6.1 fixed was that NCS service would not automatically start on boot. It now starts at boot! I was about to post another topic about this because it was another issue that was driving me crazy.


#9

Thanks and good detective work! Windows causes a lot of headache sometimes, but good you discovered what was the problem in your setup. I am running 4.6.1 on several of my systems together with NCS 132 with no problems, but you never know ;). I have Win 10 version 1511 build 10586.164. When that update was installed my problems with NCS service not starting automatically was solved. Before that update NCS service could only be started in Automatically delayed.
Is Domoticz server (nice software that I have to test!) still working correct?
For tweaking. try blob detection. That solved some of my unwanted motion detection problems. The package delivery guy is usually a bigger blob than rabbits and dogs ;).
-Henrik