Need help adding Hikvision DS-2CD2142FWD-I to WebcamXP


#1

Hi, I have been using WebcamXP for more than 10 years. Really like it. I recently has to switch out a camera. I am trying to add this Hikvision DS-2CD2142FWD-I and since this model is not in the supported list. So, I tried using the model that I thought was similar but has no success. If anyone has any suggestion as to how to get it to work. I would really appreciate it. Thank you.


#2

Hi
There are so many cameras on the market today that it is not possible to make templates for all of them. Therefore, we have created a Universal Source Filter that you can install and use in WebcamXP.
The source filter is here
http://webcamxp.com/download.aspx
and more information about how to use it is found here
http://community.netcamstudio.com/c/Universal

I don´t know what other cameras you use, but have a look at Netcam Studio that handles that type of camera much better.

-Henrik


#3

@Henrik, Thank you for your help. While trying your suggestion, WebcamXP is now stuck at loading a source “Connecting to source 4”. I even tried uninstall and re-install, still have the problem. Basically, my Webcam is not working now. I need to delete the bad setting but I couldn’t because I couldn’t get in to the program. I really appreciate if you can help me. Thank you. Steve


#4

Hi!
Typical! It seems that it is the configuration file that must be deleted. In ProgramData you have a folder for webcam. When you have uninstalled the program you have some files left there. Remove that folder. Also in ProgramrFiles or ProgramFiles x86 there is a folder for Webcam. It that is still there remove it. Install webcamxp again and start over.

When you add the camera in the source filter which URL do you use? I have two different ones here. I am not sure which one works.
rtsp://username:password@xxx.xxx.xxx.xxx:554/Streaming/Channels/101
rtsp://username:password@xxx.xxx.xxx.xxx:554/video.h264

Good luck,
Henrik


#5

@Henrik, Thank you very much. But I have my webcamxp installed in Windows Server 2012 and it has no ProgramData Folder. Do you know where else can the folder be in? Thanks again. Steve


#6

@Henrik, never mind. I found Programdata folder. It is hidden. Thank you. Steve


#7

@Henrik, I got the camera to work now. Both formats work. So, thank you very much for your help. I really appreciate it.

Thank you,
Steve


#8

Excellent!
Thanks,
Henrik