Netcam Studio v1.3.2 takes 99% of my dual core processor


#1

Hello,
I have a Dual Core computer with 3 Gb memory and Netcam Studio v1.3.2 installed.
I really do love the program but it takes all of my processor (99%).
So when recording it skips frames and freezes a lot :frowning:
The program is working great on my Core to Quad PC.
Is there anything i can do ?
I use a IPCC B13N W camera.


#2

Hi Michael! If you have only 1 camera 99% seems a little bit to much. 3GB of RAM is fine, but what processor is it, which Windows OS due you use?
°The program is working great on my Core to Quad PC°, what is that for a computer?`
-Henrik


#3

Hi, my Core 2 Quad PC is a 64Bit Intel Core 2 Quad CPU Q6600 @ 2.40Ghz / with 8 Gb Memory and Windows 10
I need to look tomorrow for the specs of the dual core.


#4

Ok, here is the info from my other computer.
It has a clean install of Windows 7 Proffesional, 3 Gb memory and a AMD Athlon 64 x 2 Dual Core Processor 4000+ 2.10Ghz
It has no other programs installed, just only Netcam Studio v1.3.2 .
I use the RTSP stream from a IPCC B13N-W (rtsp://name:password@ipadress:554/11)


#5

The computer seems to have the capacity,. Is it NCS itself or is it the computer that use the 99%? Check in the NCS window as seen below where you can see the readings for NCS.

Do you have VLC installed?
Under Settings: Client Settings and Recording Settings there are several parameters that affect cpu load.
Under Settings and Decoding/Encoding you can change between Buffered and Unbuffered to see if that helps.
Also check in the Task Manager if something else is causing the high CPU load at the same time.

Since you use rtsp I assume you connect with h.264. Can you connect using the mjpeg stream instead and see if the lower the cpu load.

Otherwise, well the classic one. Deinstall NCS completely (remove setting files in Program Data also) and install again ;).
-Henrik


#6

Hi,
I did play with some record settings.
Under client settings i only deselected “High Quality Rendering” and in camera settings i changed the sourcechannel from 11 to 12.
Now it’s not skipping or freezing frames and cpu usage is 40% (and not 99 like before)
The second stream of the cam isn’t that bad.
Thanks for the info Henrik !


#7

Good! For my own interest and future reference what was the change from channel 11 to 12 about?


#8


#9

Thanks. That explains! ;).


#10

720p isn’t a very high resolution however this CPU is about 10 years old.

I have noticed that NCS will run much better on a 2 years old little i5 than on a 5 years old 8 cores Xeon (E7-4820) for the exact same configuration in term of cameras / steeams (this server wasn’t dedicated but using a VM on it).

FFMPEG tries to use graphic card features for decoding, aspects such as RAM and HDD speed are also counting and important. A more recent computer should be able to deal with the 720p streams easily.


#11

I’m using the buid-in graphical card, is it an idea to use another one ?


#12

I doubt it’s worth investing in an old computer. If you can live with lower resolution then it should do ok otherwise consider changing the whole thing. Faster memory and fast hdd will also help a lot.

Something like that would do great, I’m using this 24/7 for 4 cameras and usually it’s not even enabling the fan:


#13

Looks great, but i don’t have the money for it :frowning:
I need to do it with the parts i have.