PTZ no longer working for Foscam 9831W


#1

Hi Henrik (and others),

Since the newest update for NetCam Studio (1.5.1) I am unable to use PTZ for my Foscam.

I have tried the following:

  • Deleting the sources and reinstalling them.
  • Creating the source both over ONVIF and as a Network Camera
  • Various profiles with ONVIF
  • Changing PTZ mode from continuous to relative
  • Completely uninstalling (including deleting the entire Moonware folders in AppData and ProgramData) and reinstalling again.

Thus far, nothing has worked. Hopefully you can shed some light. :slight_smile:


#2

Hi,
This seems to a major one :slight_smile: . No idea for the moment, but go back to version 1.4.3 where all was working to check if it is NCS or something else.
-Henrik


#3

If it worked before then it wasn’t over onvif ptz so things like continuous, relative you can probably leave beside, i would say it’s not of interest in your case.

back to template mode, the only thing that changed is the handling of the movestop command. before the time was hardcoded in the software, no it should move as long as you press the direction buttons.

did you try to press a bit longer (1-2 seconds) ?


#4

Hi Henrik/Steve,

Updated now to 1.5.4 and still PTZ doesn’t work. Either when connected via ONVIF or when connected manually as a network camera. Furthermore, the PTZ buttons no longer show up at all. =/

Any tips?


#5

Hi,
This is definitely going in the wrong direction. First, can you please install the latest official version 1.5.6 from here Netcam Studio 1.5.6 so we are on the same version. NCS have been developed rather rapidly lately ;).

I actually discovered that my PTZ buttons are gone also just now. First make sure that the PTZ is enabled in the template. Second, go to Settings - Client Settings and enable Show PTZ in multi view. Now the buttons should be back. If not save the template again. The PTZ function is modified so for the buttons press and hold down and release when in position.
Do these steps and see if we are lucky.
-Henrik


#6

Did a fresh install of 1.5.6 as described before but still no go. Oddly enough, when I set up the camera via ONVIF the buttons are there but they don’t function. If I set up the camera via the Network Camera interface they don’t appear at all.

Something else I’ve noticed as well, that I can’t say how long it’s been happening, is that the frame-rate seems to be capped at 10fps regardless of whether it’s in IR mode or Normal Light mode.


#7

OK, for this - If I set up the camera via the Network Camera interface they don’t appear at all.- I asked you in the earlier post to do this:
“First make sure that the PTZ is enabled in the template. Second, go to Settings - Client Settings and enable Show PTZ in multi view. Now the buttons should be back. If not save the template again”

-Henrik


#8

Sorry I didn’t mention, but I had done that. They buttons appeared over the ONVIF but not the Network setup until I deleted it and set it up again. Now the buttons show up in single view, but not in Multiview (though that doesn’t bother me). However they still don’t move the camera.


#9

Have you restarted the camera?

Can you give me access to the camera/computer using with Teamviewer or if you can give me access to the camera so I look a little bit closer what might be wrong. If ok I will send you a PM for exchange of details.
-Henrik


#10

Some feedback here that the mystery solved. Foscam use port 88 for the RTSP to get video and audio. Foscam also use port 88 for the http to get the PTZ working. So in the Template (Network Camera) set both http and RTSP to port 88.
-Henrik