Service crash when FTP synchronization is active


#1

Hi,

After I updated netcam to v1.3.7.2, the netcam windows service started to crash (it only stands “running” a couple of minutes). It only happens when I have the FTP Synchronization active. If I deactivate the synchronization, the service runs normally (no crash is detected). The same behaviour is detected when running the netcamStudio X. What could be the problem?

The OS is windows 10 and the detail of the error event is:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="Application Error" /> <EventID Qualifiers="0">1000</EventID> <Level>2</Level> <Task>100</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2016-11-05T17:57:59.590720400Z" /> <EventRecordID>2367</EventRecordID> <Channel>Application</Channel> <Computer>DESKTOP</Computer> <Security /> </System> <EventData> <Data>NetcamStudio.Service.exe</Data> <Data>1.3.7.2</Data> <Data>57c53f0a</Data> <Data>clr.dll</Data> <Data>4.6.1586.0</Data> <Data>575a1507</Data> <Data>c00000fd</Data> <Data>0000000000003137</Data> <Data>8ec</Data> <Data>01d235bde3b61989</Data> <Data>C:\Program Files\Netcam Studio - 64-bit\NetcamStudio.Service.exe</Data> <Data>C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll</Data> <Data>06f5f301-9a1a-4c95-b42a-11755f0c62ee</Data> <Data /> <Data /> </EventData> </Event>


#2

Hi Nuno!
I run the FTP synch with no problems under a rather long time so it must be something local. Does it synchronize any files before it crashes? Are there any warnings in the Event log when you have turned on the synch?
When you start NCS X is everything loaded normally or do you see FTP module come up in red text?

Either the FTP module is not loaded correct or maybe something went wrong in the update process. The config files should not have something to do with this, but … You can uninstall NCS and also remove the config files located in the ProgramData - Moonware to make a clean installation. Install NCS again.

-Henrik