Source(0) - Video Source Stopped due to inactivity


#1

Dear all,

When I’m streaming my video, I get this message: “Source(0) - Video Source Stopped due to inactivity” with the source: “Source(0).TimerInactivityElapsed”, once a while in my Event Log. The consequence is that my video freezes in my webbrowser and it only continues when I refresh the browser and pay some attention to the Netcam Studio.

As I’m planning to set up a webcam which will broadcast 24/7 and may have quite some ‘inactive’ moments, I want to prevent this from happening. Especially because the hosting PC isn’t located on a place which will be visited quite often.

So, is there someone who knows how to prevent my camera/Netcam Studio from going into inactivity modus? And it this a Netcam Studio error, or is it a camera problem? Thank a lot!


#2

It’s just pausing the stream to spare resources when nobody is connected or watching.

If the computer from which you watch either goes to sleep or loses the network connection then the stream on the server will go in pause until somebody requests new images.


#3

Does it still record motion when this happens,


#4

No because this won’t happen when motion detection is enabled (at least it shouldn’t).

It happens only if nobody is requesting / using the stream. When MD is enabled, then it is using the stream to detect motion.


#5

Hi !
I get the same message “Source(0) - Video Source Stopped due to inactivity” and if I start motion detector from HTTP request then no motion is enabled ! I get a good HTTP response though and if I send an HTTP request for motion detector status it tells me its enabled.

My HTTP requests are OK because if I’m looking the stream with NCS (windows) and I send HTTP request motion detector True then motion is enabled.

Any help is appreciated :slight_smile:


#6

Hi Bernhard!

I have tested on several cams and it always works in my situation. This is the URL I send for cam 3 to start motion detection:
http://localhost:8124/Json/StartStopMotionDetector?sourceId=3&enabled=true&authToken=xxxxxxxxxx

When you send this you get a “true” back and a yellow frame around the video and the bar graph in a corner of the video and clock is running at bottom right?
-Henrik


#7

Hi

my procedure is as follow :

  • launch NCS 1.3.6.8 win 7 x64
  • go to “event logs” view
  • wait for “Video source stopped due to inactivity”
  • send http request to start motion detection => I get “true” as response
  • still in “event logs” view, move my hand in front of the camera => no motion detected, no trigger, nothing
  • go to “multi view” view => there is the yellow frame and the bar graph
  • go to “event logs” view => message “re-starting source X”
  • move my hand => motion detected !

#8

Read it all!

Thanks for the detailed info. I would really like you to do this:

  • have the actual source viewing in non motion.
  • send http request to start motion detection.
  • you get the yellow frame and the bar graph.
  • is the clock running in the bottom right corner?

I am getting suspicious here that it might depend on which view you are in. I have always started with the video view, but I start in the view with event logs and see what happens. Also, I will send the command with NCS Service running and no clients open. Some testing is obviously needed :). If you have time to do the above it is appreciated.

Since the connection is inactive it might be necessary to semd a wakeup call first if that is possible.

Edit:
Yes, my suspicions were correct. In a view where the cam is inactive and one send the command to start motion detection one get the “true” back which indicats that NCS has made the changes and set the cam to “yellow alert”. However, that command do not call for the cam to wake-up. The only command that seems to wake-up the cam is one where you need to see the video. That is why it works when you switch view. It also works if one take a sneak peek under the Sources. That wakes the cam and motion detection can start. Voila, problem confirmed. So the http command motion detection must be followed by a call to the connection to wake-up.

I have not found an http command that wakes the cam up at this time, but I continue to test. If there is one you can send two commands in the meantime before this is fixed.

Thanks for your help and effort. This goes directly to our developers. I hope it can be handled ASAP.

-Henrik


#9

Thank you I look forward for the next NCS release :slight_smile:

In the mean time I just send a http request “Get Jpeg” in order to keep the stream “alive”. For now it works.