Timelapse is not synced with Google Drive using images


#1

Hi everyone,

First of all, great software. Thanks!

I seem to have a problem with timelapse not being synced to Google drive when I use images. I want to have a motion detection set up so that instead of a movie it records several images. I set up in the rules to start timelapse on motion detection, and configured timelapse to record images. The images are recorded fine in the library, but I can’t sync them to Google drive. If I record timelapse as video everything works. Do you know what the problem could be?

Thanks.


#2

Hi and welcome to the forum.
I tested this and you are correct. The folder Timelaps is not synced. When I first configured everything the folder Timelaps was created on Google Drive and some images were copied, but then it stopped. Also, the checkbox isConnected is unchecked after a while and then the sync stops. My assumptions was that the isConnected would connect again when it is something to sync, but that doesn´t happen. Also, I would like to know how it can be reset or if it follows the Retention period or what. This is forwarded to our developers for investigation.
Thanks,
Henrik


#3

Henrik,

thanks for quick reply. I also observed isConnected to turn off sporadically. I can turn it back on manually, but that does not synchronize images from timelapse. I also noticed that sometimes I would have timelapse images that do not show up in the library (through the library button). I do not know when it happens. For some reason the program does not read all the images in the library path. Could it also be linked to no sync on timelapse images?

Also, is there a way to avoid timelapse in my case? I want motion detection, but to record several still images instead of a video. Can this be done with caption? Is there a way to configure caption to start on motion detection and record, say, 5 images per second for 10 seconds?

Thanks.


#4

Hi,
Capture takes only 1 picture and store that. So that cannot be used in your example.

Disable recording of a video when motion is detected do the following:

  • go to Rule manager and disable onMotionSttart and onMotionFinnished. These 2 rules are enabled by default for all sources. When these 2 rules are disabled it is necessary to make new rules for actions to take place for any source.

To obtain 5 images per second for 10 seconds do the following:
-Use Timelaps.
-Create 2 new rules. One for start of Timelaps and one for stop of Timelaps.

-make a corresponding rule for stop of Timelaps

-go to Configuration of the actual camera source and set this for Timelaps:

-Activate Motion detection. Timelaps should now start and stop automatically when motion is detected.

-Henrik


#5

Henrik,

Thanks for these instructions. This is what I did and then realized that timelapse images are not synced with google drive. Actually, I did not disable onMotionStart and onMotionFinished rules like you are suggesting, but instead just changed the actions to “StartTimelapse” and “StopTimelapse” in these rules. Not sure if it makes any difference.

Ilya.


#6

It will not make a difference for the moment, but after the bug is fixed it will work as expected ;).
Thanks,
Henrik