Webcam XP only connecting from my phone when phones on wifi


#1

Hi,
I’ve recently installed WebcamXP ( the free version) on my laptop.
I did a test today - I left the house with Windows XP running on my laptop with the intention to check, once outside, if the camera was working from my phone . It didn’t work - the page wouldnt load up everytime I tried. It actually appears that I can only access Webcam XP from my phone when I am on wifi - ie when I 'm at home !

2nd issue - when I came back home and checked the gallery, i noticed it only took pictures during th etime I was in the house, but all or most of the time I was oustide it took no pictures/recorded no images . I saw only a series of black screens in the Gallery.It started taking images again when I sat at my pc.
Any idea how to fix these 2 issues please ?

Makeda


#2

Hi Makeda,
First issue.
When you are inside your home your smartphone connects to the LAN via wifi. When you leave the house your smartphone connects to your Internet Service Provider, your provider. Then you cannot use the IP to your computer which is something like 192.168.x.x:8100. That can only be used when you are connected in your house. To connect to NCS from outside you need to follow this Accessing Netcam Studio remotely using Web Client or Smartphone App IT is the same procedure if you use Webcam or Netcam Studio.

Second issue.
If you are running motion detection it will of cause start recording when you are in the house. When you leave and nothing triggers motion detection there will be no recordings. I am not certain how you have configured this, though.

-Henrik


#3

Hi Henrik thanks very much for your quick reply.
For problem No 1 I’ll try your fix and let you know how I get on.
For problem No 2 I had disabled movement and audio detection ( I knew there wouldnt be anyone in the house during the test period ) so that is not the problem. I suspect ( not sure though) that it is an issue with my home internet connection which sometimes interrupts itself for short periods of time periodically. I wonder if that isnt whats causing the camera to disconnect.

Makeda


#4

Henrik are you sure that by following the steps to set up a static IP address I am not messing up with my PC , other programs or applications ? I m not an IT person and wouldnt know how to fix things if that was the case… the 3 mandatory steps on that procedure, are they completely safe ?

cheers
Makeda


#5

Yes, the 3 steps that are mandatory for this to work is completely safe. I have this on all my systems to reach them from !outside" and all people that use the NCS App on their smartphones as well.
However, if this is your first time maybe it is a good idea to google on this to find more information. On youtube there are videos for everything :slight_smile:
1.set up your computer with a static IP number.
2.setup your router to forward port 8080 for webcamXP to the static IP address obtained in 1.
3.find out the public IP address to your router.

When you have done these steps and you are not on wifi open the web browser in the cell phone. Enter http://publicIP:8080 now it should start.

-Henrik


#6

Hi Henrik
Followed the link and tried to apply the steps , but had a first issue in that under the command prompt screen the DNS server listed the same address as Default gateway. So as per instructions i tried to identify the correct DNS server ip addresses. I somehow managed to get online into my router DNS page without knowing user name and password then proceeded to step 9. Unfortunately the result of that was that not only am I still not able to access webcam xp from my phone 's ISP, but it no longer works accessing it through wifi either ( not that this was ever useful anyway).
So I think I’ll leave it at that, i’m done for today playing apprentice IT expert I think ! but thanks for the advice anyway :slight_smile:

Makeda


#7

I should add that while I can no longer access webcam xp via my phone at all, clicking on the internet webcam link still works on my laptop…


#8

Update - phones connect on wi fi again ( i ve changed all the settings under Wifi properties/Internet protocol version 4 ) back to normal )