With and without SSL at the same time?


#1

Hello,

I managed to activate HTTPS (SSL) without any problem.
Unfortunately I spend some time at several places which block HTTPS at none standard ports.
Since I know that the network is save I wouldn’t mind to use HTTP (without SSL) then.
Is it possible to active the webserver at two ports (one with SSL and one without) at the same time?


#2

Hi Erik,
Excellent, because that is tricky sometimes. Did you use windows 10 own certificate or did you buy one?

Using different ports will not work. However, when I woke up this morning I had another idea in my head that you can test ;). There are two different configuration files. One for running NCS X and one for running NCS as a service. Change only one of these config files for using https and keep the other one for http. Depending on location you use the X version or the Service version. You only need to keep track of when you use the windows or the web client to use http or https. It´s early morning so I can be wrong, but test if it works ;). Please, report back how it goes.
-Henrik


#3

Hi Henrik,

I use Netcamstudio on a MS Server 2008 R2 (no commercial use) so I just created my own certificate.

Thanks’ for the suggestion.
Unfortunately the service and the NCS X seems not to be be possible at the same time.
The service always stops when NCS X is already running.
So difficult to switch when I’m away.

I tried netcamstudio without SSL but using a reverse proxy which takes care about SSL.
But I couldn’t get it to work event without SSL.

Before I bought netcamstudio I evaluated a software called go1984.
Very nice software but way to expensive for private use.
They allowed both http and https at the same time using different ports.
Maybe something for the “suggestion” list of netcamstudio :slight_smile:

Cheers
Erik


#4

No no NCS X and NCS Service cannot be at the same time. The idea was for example to run NCS X with http OR NCS Service with https. Switch using TeamViewer ;).

A very different price for go1984, but that makes the difference :wink:

-Henrik


#5

I do not understand your problem why can’t you use 443 port ? is it because NS do not allow “custom” listening port ? can’t a port translation/tunnel help you ?


#6

I already have IIS providing another service on port 443 on this machine.
So I thought a reverse proxy might be a good idea.
But I can’t get it to work properly.
Maybe somebody know the correct settings and can point me in the right direction…

When I’m at the other location I need to access the internet via a proxy server.
So I guess this is blocking quite a few things.
VPN would work but is not allowed.


#7

OK now I understand better :wink:

Which reverse proxy are you using ? NGINX ? do the reverse proxy also do SSL Offload ?


#8

I’m using the “URL rewrite” in IIS
Today I had another look and finally it seems to work.
I created a special subdomain for this and redirect all the traffic to the netcamstudio port.

Thanks’ for trying to help.


#9

Hi,
Congrats and thanks for sharing “how to” for the next user!
-Henrik