Xiao Fang stuck to 10fps


#1

Hi

I have a Xiaomi Xiao fang cam . And i run https://github.com/samtap/fang-hacks to enable rtsp.
when i stream from tinyCam Monitor i get 25 FPS but when i use rtsp://device-ip/unicast in netcam studio i only get 10 FPS.
I have other cams also ex Xiao Yi (ant cam) and with that cam in Netcam studio i get 30 FPS.

Anybody who know why i only get 10FPS in Netcam studio with this cam?

Br
Christopher


#2

Is stream type rtsp_tcp or rtsp_udp? If you run it through VLC. What is the result?


#3

I was in China 2 weeks ago. If I knew I would bring one of these back.

Anyway our control on FPS is pretty limited so yes please report on the results you get using VLC. I will already give a reference. Normally you should get similar results with NCS.


#4

I tried booth rtsp_tcp or rtsp_udp with same result. 9-11 FPS
I dont know how to see frame rate in vlc but video is playing


#5

Even if you don’t see the FPS in VLC you should be able to see visually if it’s around 10 or around 20.


#6

I run high res/high fps cams. They work flawlessly on other software, but in NCS the framerate drops down to 8-9fps and sometimes the image lags and gets all messed up, WHILE other programs still shows the same camera flawlessly and at higher fps. I’ve payed for a 16 cam license, it looks like I just payed for a few functions, main video feed is way better on other free software.


#7

The latest 1.3.9.1 release allows to allocate more than 1 thread per source which will should allow to enable more resources to decode more efficiently (however it will probably require more cpu and more memory when enabled).

Netcam studio decodes everything but re-encodes its right away so that it can be shared with clients (windows, mobile and web) so it makes it somehow more demanding by design due to this process of re-encoding before displaying the stream.

Finally it’s not really recommended to connect the same stream from a camera in 2 apps, some (high-grade) cameras will do it without problems but most of the cameras I saw are not able to properly encore 2x in full hd stream and it won’t be as smooth and as stable in term of FPS as it is when there is only 1 client on a given stream format.

Finally if you’re still using your amd laptop, then try to move to an intel based setup (ideally an i7) on a fixed computer and you’ll probably also get much better results.


#8

Also, just to add I was working on this problem for a couple of days ago where the cpu load was 100% and if you are running version 1.3.7.2 there is a checkbox in the Recording tab for Background recording. That box should be unchecked! But, move up to the latest release 1391 is best.


#9

Also in the client / x settings, ensure to untick the high quality rendering. on a laptop the fact of anti-aliasing the result when displaying on screen can also impact the performances (and disabling may allows to win a few FPS).


#10

I’ve ordered one of these as it costs 25€ (includes free shipping from hong-kong) however i won’t be here before 2-3 weeks…