2 Feeds Conflict on new Netcam 1.8.1 & 1.9.0

Since Installing, updated and unistall / reinstall from fresh netcam1.8.1, out of 16 cam feeds i have, these 2 are from the internet (external addresses) and when run together the feeds stop after about 10 - 15 mins (red boxes around the feed), once you untick and retick them, they come back alive for another 10 - 15min then drop again.

Never had an issue on older version of the software - for the past 3-5 year.

RTSP_HTTP
https://stream-eu1-charlie.dropcam.com/nexus_aac

MP4/RTSP_HTTP
https://edge04.hdontap.com/ingest03-hd3/watersp

do you know what is causing the issu. BTW - tried on 2 different PC’s

logs show : has been lost. Will try to reconnect in 2 seconds…

Streams are live and do not drop in Chrome.

Thank you
Paul

Update : Gone up to 1.90 and I get the same result

Hi,
Please install latest version of Netcam Studio 1.9.0 since there have been some changes.
How about VLC?
The URL´s are not complete. Paste them with Preformatted text.
I will look into this also.

-Henrik

Also can’t open the streams neither in Chrome, VLC or Netcam Studio.

Chrome just says:
Wowza Streaming Engine 4 Subscription Edition 4.7.4 build21380

And VLC, something like:
http debug: outgoing request: GET /nexus_aac HTTP/1.1 Host: stream-eu1-charlie.dropcam.com Accept: / Accept-Language: en_US User-Agent: VLC/3.0.8 LibVLC/3.0.8 Range: bytes=0-
http debug: incoming response: HTTP/1.1 200 OK Access-Control-Expose-Headers: Date, Server, Content-Type, Content-Length Cache-Control: no-cache Server: WowzaStreamingEngine/4.7.4 Access-Control-Allow-Origin: * Access-Control-Allow-Credentials: true Access-Control-Allow-Methods: OPTIONS, GET, POST, HEAD Connection: Keep-Alive Access-Control-Allow-Headers: Content-Type, User-Agent, If-Modified-Since, Cache-Control, Range Date: Fri, 24 Jan 2020 21:20:47 GMT Content-Type: text/html Content-Length: 178
main debug: using access module “access”
main debug: looking for stream_filter module matching “prefetch,cache_block”: 24 candidates
prefetch debug: using 178 bytes buffer, 178 bytes read
main debug: using stream_filter module “prefetch”
main debug: looking for stream_filter module matching “any”: 24 candidates
prefetch debug: end of stream
lua debug: Trying Lua scripts in C:\Users\machina\AppData\Roaming\vlc\lua\playlist
lua debug: Trying Lua scripts in C:\Program Files (x86)\VideoLAN\VLC\lua\playlist
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\anevia_streams.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\anevia_xml.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\appletrailers.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\bbc_co_uk.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\cue.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\dailymotion.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\jamendo.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\koreus.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\liveleak.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\newgrounds.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\rockbox_fm_presets.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\soundcloud.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\twitch.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\vimeo.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\vocaroo.luac
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\playlist\youtube.luac
main debug: no stream_filter modules matched
main debug: looking for stream_directory module matching “any”: 1 candidates
main debug: no stream_directory modules matched
main debug: attachment of directory-extractor failed for https://stream-eu1-charlie.dropcam.com/nexus_aac
main debug: looking for stream_filter module matching “record”: 24 candidates
main debug: using stream_filter module “record”
main debug: creating demux: access=‘https’ demux=‘any’ location=‘stream-eu1-charlie.dropcam.com/nexus_aac’ file=’\stream-eu1-charlie.dropcam.com\nexus_aac’
main debug: looking for demux module matching “any”: 55 candidates
main debug: looking for xml reader module matching “any”: 1 candidates
main debug: using xml reader module “xml”
webvtt debug: subtitle demux discarded
mod debug: MOD validation failed (ext=com\nexus_aac)
avcodec debug: trying url: \stream-eu1-charlie.dropcam.com\nexus_aac
avcodec debug: CPU flags: 0x0007d3db
avcodec debug: couldn’t guess format
ps warning: this does not look like an MPEG PS stream, continuing anyway
main debug: using demux module “ps”
main debug: looking for meta reader module matching “any”: 2 candidates
lua debug: Trying Lua scripts in C:\Users\machina\AppData\Roaming\vlc\lua\meta\reader
lua debug: Trying Lua scripts in C:\Program Files (x86)\VideoLAN\VLC\lua\meta\reader
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\lua\meta\reader\filename.luac
main debug: no meta reader modules matched
main debug: `https://stream-eu1-charlie.dropcam.com/nexus_aac’ successfully opened
ps warning: garbage at input from 175, trying to resync…
main debug: EOF reached

Morning

I have the same on 1.90

Thank you
Paul

https://edge04.hdontap.com/ingest03-hd3/watersplash_visitjersey.stream/chunklist_w695006546.m3u8

https://stream-eu1-charlie.dropcam.com/nexus_aac/509cb5e706f54b42bfc01dcaf4ef5e74/chunklist_w1073090896.m3u8?public=ZSB7egmHsN

This one works fine and does not error out ever;

https://s34.ipcamlive.com/streams/225dff505eace5e2c/stream.m3u8

here is a different link to one of the feeds, but could not get this working in the app, but play fine in Chrome : https://video.nest.com/embedded/live/ZSB7egmHsN

Regards
Paul

Thanks, links works better this time. Nice views.
Added all three to NCS 1.9.0 and we´ll see what happens.
-Henrik

1 Like

Yes, I have this also. But they restarted automatically after 5 minutes. Tricky.
We will be back :slight_smile:
Thanks,
Henrik

Good News, do you still have the older version of the software installed to make a comparison? As this was not present in 1.7 …

Thanks
Paul

Hi,
I tested with VLC and the first link demanded a security certificate to open and the other links did not open at all
image

If VLC cannot open them it will not work in Netcam Studio either.
-Henrik

https://edge04.hdontap.com/ingest03-hd3/watersplash_visitjersey.stream/chunklist_w695006546.m3u8

https://stream-eu1-charlie.dropcam.com/nexus_aac/509cb5e706f54b42bfc01dcaf4ef5e74/chunklist_w1073090896.m3u8?public=ZSB7egmHsN

Both work in VLC so not sure why you see the errors on the app

From last night I have them in Netcam Studio. This morning lost connection to one of them and it do not reconnect. This is public cameras and what they stream or how many that are using them will affect so …

We’re still working on your streams and looking forward to improve things.

They are horrible to deal with and handle but we’re doing our best :slight_smile:

Big problem is that they require a lot of buffering (above 600 frames to work perfectly which I’ve managed) due to the fact they send a lot of frames, then nothing for 5-10 seconds again a lot of frames, etc…

But little by little, we’re getting somewhere and it’s better and better…

1 Like

1.9.1 defo sees improvments to the feeds I had issues with, been running all day and zero drops.

Hi,
Yes, these cameras a.k.a the bad boys, really gave us a headache :slight_smile:. They are both unstable and send data in a very peculiar way. However, I think we finally made it to work. An important parameter for this is in Settings-Decoding-Decoding Buffer. Since they send data in bursts a longer decoding buffer helps. This will also increase memory use.