Broken streams when running in service mode


I have a setup with 4 MJPG streams coming from an Axis 240Q and 2 others coming from a linux machine. When I run the server application manually, everything works perfectly. If I start the Windows service instead (so it will automatically run at boot), then only the first two streams from the Axis device work. The other 2 streams from the Axis show “Error in Camera Downloader - Parameter Incorrect”. The 2 streams from the Linux machine work OK. The software is licenced for 16 streams.


I see that the Axis 240Q is a video server for analog cams and you get the mjpeg streams over the LAN. Usually that error message indicated problems with username/password.
When you run as a service you use the windows client to connect. We have some strange things going on with the windows client so I would appreciate if you can do the following tests:

  1. run NCS as service and connect with windows client. Here you have the problem. Stop the service and start NCS X. Is everything OK or do you have the problem now also?
  2. run NCS X and all is OK. Connect with the windows client. Do you still have the problem in the windows client?
  3. run NCS X and connect with the web client. Problems?
  4. run NCS as a service and connect with the web client. Problems?

Is the problem always for the same two streams or is for example always for source 3 and 4 in NCS that have a problem?

Finally, is this a new installation or is it an upgrade from en earlier version of NCS that works?

If you want you can also forward the stream from the AXIS cams and I will check here on my system. If you want that I will send you a PM where you can send data.




I have the same problem. In NCS X mode, I see all seven camera video streams with no problems at all. In NCS Service mode, I see two streams and “Connecting… Unable to connect” for five of the seven cameras. The same two cameras are always the ones that work.

I have six D-link Cameras (DCS 933Ls, DCS 2330L, and DCS 930L) and one Wansview (NCM625M) camera.

The D-Link DCS 2330L and the Wansview cameras are the two that work in Service mode. The DCS 2330L uses H.264 and the Wansview uses RTSP.

Two of the non-functioning (again, in “Service” mode) D-Link cameras (DCS-933L) use H.264 and the three non-functioning (“Service” mode) D-Link DCS-930Ls use JPEG mode video streams.

I’ve searched the forum and haven’t found any ideas for solving this.

Thanks for taking a moment to reply.

Kinsman Farm


“Interesting” problem as we say :slight_smile:
Since NCS X and NCS Service use the same resources it should not be any difference. However, computers …
Test this:
Run NCSX where all cameras work. Delete one of the cameras that do not work when running in Service mode. Stop NCSX and start NCS Service mode and connect with NCS client. Add the same camera that you deleted earlier. What happens?



Thank you for a rapid response. You are very faithful!

I will do the test as you describe. Funny, I thought that cameras could only be added in the NCS-X mode. I learned something important just now.

I will reply soon with the test results




Thank you for your recommendation.
I found success, using the following steps:

  1. NCS-X running, 7 cameras functioning normally (models, streams described in thread above)
  2. Disconnected non-functioning D-Link Model 930L
  3. Stopped NCS-X
  4. Started NCS- “Service” and Opened NCS-Client, 6 cameras, 2 functioning normally (ref. earlier in thread)
  5. Added the D-Link 930L camera (in NCS-Service mode), using the exact same setup as before (Make/Model/IP/port/login, etc)
  6. FAILED - Test Connection Login (“timed out”), re-tried with same FAILURE result
  7. Frustrated, I tried to connect using D-Link (brand) and “CAS 200W” (the FIRST model on D-Link’s list)
  8. Test Connection SUCCESS for video stream (all I care about, btw) - Oddly, this model is limited to “JPEG”
  9. Closed Client, Stopped Service.
  10. Started NCS-X - All 7 cameras functioning normally. Test camera (Steps 2, 5, and 7 above) set to Model “CAS 200W” -as described in step 7.

Henrik, it’s just as you said above: “However, computers …”

Kinsman Farm


Thanks for your report and support!
Good luck,


Hi all,

I have similar problem, break stream even in client or server mode with the cameras DCS 930L , this template is not working in my computer version NCS 1700 . I did a test using the lasts suggestions in the forum. The cam is working with CAS 200W in JPEG template , the right should be 930L template working in MPEG. How to solve this issue?
PS:The camera I have browser access…


Hi there,
Sorry, but this model is a terrible to work with. However test this.
Add the camera by the tab for Custom URL.
Set stream type to MJPEG
In Address use

For JPEG test



Custom URL works fine! The template is intermitent sometimes works fines but suddenly stop. Tks for suggestion.