Constant licensing issues


Hi all,
I have been using this product for about a year now and really enjoy it except for one thing. A while back I switched over hardware to a better machine and immediately the license became invalid. I wrote into support and it took almost a week for someone to get back to me after I threatened to revoke my paypal payment for the license. Its been working fine since until I upgraded to the latest version a couple of days ago. Its now telling me invalid license again. Why is that? Its a little frustrating to have this keep happening. Ive sent another support request but I sure would like to just have a quick way to fix it instead of waiting for another week for the reply from support.


Hi there,
I hope 20 minutes is not too long for you to wait for support :wink:
Yes, that sounds really annoying. Switching hardware results in an invalid license since the license is based on the hardware. Upgrading to a newer version should not have this effect, but some other users have also mentioned this problem. The last user was running NCS in service mode. Stop the service and start NCS X again. NCS contacts the license server and with that it was solved. Maybe you need to click on the licensing key again. If you have a 4 license key this seems to be solved by doing a clean installation of NCS. Uninstall and install again if that solves the problem. If not, uninstall and also remove what is left in Program Files and in ProgramData-Moonware. Install NCS again.
Obviously we need to check this. What OS are you using?


Thanks for the quick reply. Ill give that a shot. I was running NCS in service mode and it wasnt working but had left it on. I am running Windows 10 but decided to install Server 2012 right after I posted my first post. After thats done Ill set it back up and see what happens. Ill post the results then.


After installing server 2012 and reloading the software I was able to enter my serial number and everything works again. Thanks for your help!


Good! Just remember that you can re-enter the license key 3 times. You have used two of them. The fourth time it will be not valid. However, just contact support and they will release the license again.


Just a question that might help us in this. Did you use Virtual Machine in this case when the licensing problem occurred? If so which Hypervisor/VM?


Hi Henrik,
No I use physical hardware for my video environment.



Sorry, I mix in this thread.
I’m very concerned about the license rules for hardware changes.
Why ??? Should you have an income because your customers either upgrade or have a motherboard that is defective.
Your customers already have ample expenses for equipment / spare parts and do not need a total unnecessary additional expense on yours, by the way, very nice software.
There has already been paid for the upgrade. And it’s no matter what it costs, it’s more principle.
I thought it was quite rough and grisly to do business that way.
Especially when you do not clearly draw attention to it.
On the other hand, it can be an effective way of losing customers.
At the competitor ISPY, you do not pay extra for hardware changes.



Hi there,
I am happy to say that you are completely wrong. Yes, if you change hardware the license is not valid anymore. Just contact support and the license is released at no cost and you can do the licensing processes again and it works!
This license method is chosen so that one license cannot be used on several machines. I think that is fair. You get the complete software for free for 2 cameras! That is very generous.
For some configuration of virtual machines this might cause a problem like for a Linux host, but we do not test NCS in virtual environments. I myself run NCS in a virtual machine in ESXi and it works like a charm.

Please, inform me if you have had any issues with this.



Thanks for quick reply.
Well I´m happy with that.
And yes It´s absolutly fair AND generous.
I plan to run on win10 with no virtual enviroments.
Do some testing for now.
Can’t make NCS use my local ip only with no access from my phone.
Ports 8100 8120 8124 IS forwarding to in Ubuntu IPTABLES.


Henrik, Im at a stand still again. This time I upgraded the OS and having license issues once again. Can you prod support to reset me again? I submitted a ticket an hour or so a go and havent heard anything back.


Yes, I saw the ticket and it’s a little bit longer than an hour for that. I don’t have access to the license server.

unlisted #13


Well darn the bad luck. About how long you estimate?