Fentac V380 Connection


@thecosmicslug Header contains the length. Try replacing in update file without modifying it’s size. After that calculate the checksum and apply the patch again.


Finally I succeed to open RTSP stream on my pretty old Fedora-17 box. I couldn’t get VLC up running, but it turned out that TOTEM Movie Player has RTSP support built-in. All you need to do is : Movie -> Open Location … and enter rtsp://user:pass@ip-address/live/ch00_0 or rtsp://user:pass@ip-address/live/ch00_1
Replace user,pass and ip-address with your values.


I got a new €15 camera that uses the V380 app and lack all other ways of accessing it. It is a totally round small camera that are supposed to hang on a wall. It had version PCARD_V50_V2.5.6.2 and I used the patch file on it and it worked to open up a RTSP stream.

Thanks for sharing the file and solution to others!



First Patch is also working with light bulb camera (that works with v380 android app). Thanks for sharing the solution!!
RTSP works fine,
Telnet works but password is not known
Maybe also ONVIF can be exposed, I’m trying to learn how
I’m not familiar with that patches but maybe it’s also possible to copy the password file to the sdcard, or set a new root password, or add a new user.
My cam has also a light that can be turned on/off from the android app, I’d like to control it via pc. I’ve found decompiled v380 app (https://github.com/brusdev/V380-SDK) but I haven’t already found how the light is managed (I suppose is controlled like a ptz). Grabbed some network data but nothing easily readable.


Ok, with second patch (from smashin) i can logon in root shell.
Found how to turn-on/turn-off/read-state of the camera led:

/mvs/apps/gpiotest 10 r --> reads led status
/mvs/apps/gpiotess 10 w 1 --> turn on leds
/mvs/apps/gpiotest 10 w 0 --> turns off leds

Now i’m searching a way to make that commands reachable externally… Maybe http or mqtt or tcp


I’ve a Q6 v380 smart net camera.
Thanks for the second patch, it’s works fine, telnet and rtsp.
Is it possible to move the camera with rtsp ?


Hi, I’ve applied the second firmware update to my V380 camera and now I can connect to it through RTSP 554 and telnet ports. But there is no password to the streaming access.
Is it possible to change the admin password?
If so, how?



thanks to you all.
finally i can capture my camera using vlc media player.
but i can open from browser. and i need the darkmode.
can i capture in darkmode ?


What is the URL in VLC?


Now I have another camera that uses the V380 plattform and it has firmware HwV380E23_WF3_PTZ_ETH
It’s totally unresponsive to everything except the V380 app. The patch file didn’t work as it checks what FW version the camera has and this one are not compatible.

Anyone got E23 version to work with rtsp?



I too would like to know how to enable some password on the RTSP server if anyone knows?


Hi @sk8darr, do you know if this upgrade works for VESKYS cam? I bought this one https://www.gearbest.com/ip-cameras/pp_009429741294.html and can’t access with rtsp and telnet.

Thanks in advance!


Hi @martink. I really do not know and i don’t think so =(. I recommend you to write email to the manufacturer for support with this camera.

Good luck!


Hi @sk8darr I bought a camera which I have set up with the V380S app. It only has ports 5050,5051,8800 and 8899 enabled. ONVIF Device Manager can detect it but not start a stream because there’s no RTSP port.

I tried the update files linked earlier in this discussion but it did not help.

The app says the current software on the device is

System app: AppGMS_CARD_V3.5.0.5_20170629
Kernel: KerGMS_V1.7.2.0_20170524
Firmware: HwGMS_WF3_CARD_20160217

Any suggestions on how I could adapt your patch to work on this camera?



I wrote to v380technical@gmail.com who immediately send me back a patch that worked for my camera. Now enjoying RTSP!


Obviously they have discovered that upgrade to rtsp is good for marketing and increase sales :smile:


Did you find a solution?
As I have bought a camera with the same version and the patch doesn’t work for me as well.



I think I sent an email to support but never got a reply.
Maybe a second try will be more successful.



I got a reply just after 10 seconds and after sending a screencapture of firmware versions I received upgrade files that you put on a SD card in the camera. He wrote that different versions needed different upgrades, we know that from earlier experiances, so ask for support for V300-V380 based cameras at v380technical@gmail.com

My version where originally:


and upgrade changed that to:





Thank you all.

I just bought a V380 camera and was able to open ports 23 and 554 for RTSP with the update shared here.

Camera details:
Software Version: AppV380E11_IP38_ETH_V2.5.0.9_20171120
Kernel Version: KerV380E11_IPC38_ETH_V2.1.0_20160506
Hardware Version: HwV380E11_WF1_IPC38_ETH_20160217

I Used the version shared by @ smashin