Google Drive "Authentication Url has not been received..."

Hi. In trying to get Google Drive notification/synch working, I somehow got Netcam Studio into a state where if I click the “Login” button on the notification dialog, a message box pops up saying “Authentication Url has not been received…”

Is there someway to reset something so I can get back to the Google Drive login page again when clicking the “Login” button? Thanks!

Hi! Have you tested to Restart the Service if you are running Netcam Studio as a service or kill the process if you are running NCS X (server).

Hi, Henrik. I’m running NCS X, not the service. I’ve tried restarting NCS X many times, but I keep getting that dialog.

I’ve tried deleting the .db file in the ProgramData/Moonware/etc., thinking that something was saved in there, but that didn’t make a difference.

I haven’t tried just uninstalling and reinstalling Netcam. I suppose I may as well try that in case that’s the easiest fix, but would like to know how to correct it if I somehow get NSC X into that situation again…

Hi! The settings are not in the .db file. Easiest is probably to uninstall and install again. However, when you do that 3 files are not deleted since they contain info about cam settings etc. so when you update NCS you do not need to add all cams and settings again. Most likely one of these files are corrupted. The files are located in the ProgramData… as you have already found. Remove them. It might be something left in the regular Program … also. Remove everything to be safe. Unfortunately, I do not know how to correct this if these files get corrupted in any way. Then it is to start all over.

Something’s really broken with my Google Driver synch option in NCS. I’ve uninstalled and reinstalled and deleted the related directories more than once, and I’m not able to recover.

Currently the situation is that after reinstalling, when I click on Login for Google Drive, the window that opens shows I’m already logged into Google Drive. I’ve tried logging out in that window and logging in again, and that doesn’t seem to help. NCS’s window still shows “Sign in is required to upload”.

Dropbox synch on the other hand doesn’t seem to suffer this issue. Even after uninstall and reinstalling, Login to Dropbox is fine and NCS shows me as authenticated for Dropbox.

I’d rather use Google Drive, though. If anybody has any idea how to completely “reset” the Google Drive synch of NCS so I can start over successfully, I’d really appreciate it.

Try this. Download the Google Drive Desktop app and connect from there. I assume that will work. Try to connect from NCS again. For some time ago Google changed their security system when connecting with apps. For example to connect to Gmail from NCS it is necessary to make a change in the google account to accept the lower state of security. It might be the same issue here.

I downloaded Google Drive, and it works fine, and I do know that my “lower security” allow is enabled. I’m still getting “Error in GoogleDrive.Connect(). Login out…” in NCS’s event logs.

I’m actually able to take the “Login” page’s url from NCS (""), paste it into IE, log in, click on “Allow” on the subsequent “Netcam Studio would like to:” page, and successfully get a “code” (“token”?) back from, so I don’t know what NCS is not liking when I try the login in NCS.

To do the uninstall/reinstall test, I had to download the latest version, which I noticed was released fairly recently. The last time I had Google Drive synch working in NCS was on an older version. Is it possible that the latest version has a bug in this area…?

Ha, it seems that you are correct. I installed version 1.3.0 and it connected to Google Drive. Version 1.3.2 do not. I know it was a problem with Dropbox that was corrected and maybe that also affected Google Drive. However, I will send this to our developers to attend to as soon as possible.

Ooh, thanks for testing it, Henrik! Hope we’re right and a fix is forthcoming.

btw, Henrik, I did look for an older version to test my suspicion prior to posting it, but I understand older versions are not made available for various reasons. Perhaps they can be made available with the caveat that they are available for testing purposes only? That would have saved me a lot of head scratching, to be honest… :sob:

Yes, I completely understand. After download a new version I rename it and add the version number to save them for future needs. Cause you never know … ;).

Henrik, would you be willing to upload and share somewhere an older version that still had working Google Drive support? I’d really rather use Google Drive than Dropbox, and I don’t know when a fix might be available. :confused: …Thanks!

Hi all!
Anyone who sees the same problem - please check server startup log. There must be intialization errors.
The only reason for “Authentication Url…” error is missing GDrive plugin (or if it fails to load at server startip).
Or just take Context_xxx.log from “C:\ProgramData\Moonware\Netcam Studio\Server” and upload it here.

Hi, Mikhail. Look at this “Context_xxx.log”:
after login through Google Drive it shows the request code but immediately closes the window