Google Drive Sync issue in 1.3.5


The current version has a problem
Error in Google Drive connect.Connect time out…
Previous version is good working,but now not.I reinstal,but not good.
Log file


Hi Richard! Yes, I can confirm that. Version 131 works. Thanks for the log file. I ask @Steve to look into this.



I think I have located where it comes from, I was suspecting a missing library but it doesn’t seem to be the problem.

Please give a try to the following solution.

  1. Stop Netcam Studio X

  2. Edit NetcamStudioX.exe.config

  3. Replace the part located between
    by this :

There is apparently nothing missing in the distribution package, just missing one declaration in there.

Probably the same would apply to NetcamStudioService.exe.config


Excellent! That solved the problem in both X and service version. Will this be for 136?
Muito bom!


I am updating the packages of 1.3.5 since it doesnt require to modify the binaries (and since 1.3.5 is announced as fixing issues with Sync plugins)

Thanks for confirming


Perfect! It Works.
Thank you very much.


Hi again!
I upgraded
Again, there is a problem.
The program synchronizes a drive to upload.
Then delete the folder after 3-5 minutes.
What the ??
enter link description here


For mister developer @Steve to look into.


Thanks Henrik!
I wait.


Sorry for the delay, have to forward one more time for @Mikhail_Burilov since he knows this part better than I do.


No problem,i wait and thanks!


Issue confirmed, synchronization code was partially rewritten. I think, it happens when both file is uploaded and cleanup happens. Upload code creates folders and starts uploading file, then before it finishes - cleanup function removes folders. I could reproduce this just once and now it shouldn’t be possible.
As for errors in log - this is fixed too. Cleanup procedure tried to remove some items twice.