Netcam Studio does not start - problems with KERNELBASE.dll

Thanks again.
I just followed all the steps, until start NCS. UAC asks for permission to make changes, and then nothing happens.

Yes, admin account.

Hmm, I deleted the folder C:\ProgramData\Moonware\ and it did not show up again after reinstallation. (no lic.dat file to worry about, though)

Do you have an antivirus program running apart from Windows own?. I know that that has been an issue for some users.

No, only Windows Defender.

This has for some reason generated problems at startup:
-stop Netcam Studio.
-go to C:\Users\henrik\AppData\Local\Moonware (chnage henrik to your account) and delete all.
-go to C:\Users\henrik\AppData\Roaming\Moonware (chnage henrik to your account) and delete all.
-go to C:\Users\henrik\AppData\Roaming\Moonware Studios (chnage henrik to your account) and delete all.
-start NCS and …?

Thanks again for your support.
Unfortunately, I will not be able to try this until I get home again this evening.
I’ll get back to you as soon as I can.

Hi again.

Just tried the above, except Moonware Studios is under Local, not Roaming. But it made no difference. Also tried uninstalling and reinstalling NCS with the above folders empty, but still no difference.

Getting frustrated…

Yes, me also! Can you give me access to the computer?

Yes, I guess. How do I do that?

With Remote Assistant, I guess. When is a good time for that?

Mine did exactly this when I reinstalled ncs on new server. I used the existing license file (license.dat). When Henrik reset my license and I reactivated it on the new hardware the service started no probs :grinning::+1:

Thanks for the info. However, since my needs are limited I use it without a license.

Henrik, could the (lack of) license be the issue? I don’t need the extra features of the paid license, but if paying the 49 bucks solves my issue I’ll be happy to do so.

Sorry no. It should run perfectly without a license.

Trying to start Server gives two errors in Windows Event Viewer:

Application: NetcamStudioX.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.InvalidOperationException
at System.Diagnostics.PerformanceCounterLib.GetStringTable(Boolean)
at System.Diagnostics.PerformanceCounterLib.get_NameTable()
at System.Diagnostics.PerformanceCounterLib.get_CategoryTable()
at System.Diagnostics.PerformanceCounterLib.CounterExists(System.String, System.String, Boolean ByRef)
at System.Diagnostics.PerformanceCounterLib.CounterExists(System.String, System.String, System.String)
at System.Diagnostics.PerformanceCounter.InitializeImpl()
at System.Diagnostics.PerformanceCounter…ctor(System.String, System.String, System.String, Boolean)
at System.Diagnostics.PerformanceCounter…ctor(System.String, System.String, System.String)
at Moonware.Common.ProcessorUsage…ctor()
at Moonware.Controller.ClientController…ctor(DevExpress.XtraEditors.PanelControl, Moonware.Common.NetConfig)
at Moonware.Netcam.XtraConsole…ctor()
at .…ctor()
at ..()


Faulting application name: NetcamStudioX.exe, version:, time stamp: 0x5e430f5f
Faulting module name: KERNELBASE.dll, version: 10.0.18362.628, time stamp: 0xf96f12ee
Exception code: 0xe0434352
Fault offset: 0x000000000003a839
Faulting process id: 0x2810
Faulting application start time: 0x01d5e7631257a289
Faulting application path: C:\Program Files\Netcam Studio - 64-bit\NetcamStudioX.exe
Faulting module path: C:\windows\System32\KERNELBASE.dll
Report Id: eb99e169-9ae3-465e-876d-7f0f9b77f271
Faulting package full name:
Faulting package-relative application ID:

Thanks for that info. Crash due to KERNELBASE.dll is a Windows problem and reinstalling Netcam Studio will not help. A search on the Internet gives solutions and to reinstall that dll file. Check that.

Ok, thanks.
sfc /scannow did find any errors, and despite many hits on kernelbase I could not find any working way of replacing or updating that file. I’ll just reinstall Windows, I guess.

Before you start that process test NCS on another computer if possible.

Yes, I did, no problems there.

1 Like

I had a backup system image from Sep 19, which I restored. Thereafter NCS would start, but inform me that the version was too old and force me to update. After that it would start, but subsequent Windows updates would lead me back to the same kernelbase.dll error. Is there any order these these things should happen in, ie, better to update NCS before WIndows or vice versa?

I don´t know.
It works on another system so obviously you have a problem with this system. Since you use the free version only latest system will work. If you install Windows again it will probably work.