Netcam Studio "Process & Service" cannot be terminated

After trying out the free version of WebcamXP I moved on to Netcam Studion but still have a very similar issue with closing the application and shutting down my PC. :confused:

Despite closing the server down (using the Stop Server command from the System Tray icon) and exiting the GUI (using the red X in the tool bar or Exit from the System Tray) both the “Process” (which indicates “Working Memory” is increasing and decreasing every so often and cannot be manually terminated) and “Service” (showing as “Stopped”) remain visible in Task Manager. When trying to either “Restart” or “Shut Down” my Windows (7 Ultimate x64) PC it hangs for ages and on restating Windows reports an error “Windows recovered from an unexpected shut down”

Also, if after closing Netcam Studio and not restarting Windows, restarting Netcam Studio results in a second “Process” and “Service” appearing in Task Manager and the server doesn’t connect to the Logitech webcam.


After restarting Windows to clear the error, and with the expected error report, previous recordings no longer appear in the “Gallery” although the files remain in the “Recordings” directory.

I’ve also tried apps like “Task Killer” but that doesn’t work either. :unamused:

Any suggestions how to avoid this would be appreciated.

What version do you run ?

The fact gallery is not saved is a known problem with 1.1.7 - 1.1.9 when .NET 4.5 is not installed. In the event logs you probably have an error at the time of saving or loading the file containing the gallery.

Please install .NET 4.5 to use this version or try with 1.2.0 where we have changed the format of the library so that it should work with only .NET 4.0

Anyway monitor the errors reported in the console or netcam studio logs


Thank you very much for your reply.

I have .NET 5.4.2 installed and was using version 1.1.9 when I initially reported the problem (that is after my initial tests with WebcamXP hence my edits and also moving this issue to the right thread). :smiley:

I uninstalled 1.1.9 and removed all the detritus remaining in C:\Users\George\AppData\Local\Moonware_Studios and
C:\Users\George\AppData\Roaming\Moonware_Studios etc.
and checked the registry for any potential remains so as to
ensure a clean install of 1.2.0 beta 2.

(F.Y.I. uninstalling 1.1.9 did leave an entry in the registry start up which I removed manually while 1.2.0 now doesn’t appear to leave anything behind. I discovered this while trying to fixing the problem by repairing .NET (again) then uninstalling and reinstalling 1.2.0)

After I re-installed 1.2.0 beta 2 the issues remain… I have a few screen shots to illustrate the problem.
Left overs in Program Files

**Registry left over shown by Autoruns **

Registry left overs which I removed

Another issue I’ve just discovered
I had tried to restart without rebooting but the webcam was not found so I tried to remove the original webcam and set up a new instance (the same webcam) but it crashed.

Perhaps I can help by demonstrating the issues using Teamviewer if you’d like further details on the problems I’ve encountered?

Anyway, I really do like this application very much indeed and I’d be very willing to assist in any way I can to resolve the problem. For me it seems to be the perfect solution for the situation I have in mind… :smiley:… which is trying to assist in caring for an elderly relative (my 94 year old Mother) who lives 500Km away. Naturally with her knowledge and approval.

Skype is just too challenging for her and trying to explain how to reboot if there’s a crash is way too daunting a prospect. :anguished:

**** Update 19/6/15 ****
I’ve also tried to kill the processes forcefully using the elevated command line but, as you can see, while the response is positive .i.e. the processes are terminated, they remain when viewed in Task Manager.

I could live with the need to reboot when there is a problem BUT for the fact that my data drive D: is a RAID 1 configuration of 2x2Tb discs which, over the past two days have never managed to resync so overall performance when using applications like Outlook are very slowwwww.

Cheers, George

I have tried to reproduce without success.

However the fact that it happens with both Netcam Studio and webcamXP, i’m wondering if it doesn’t come directly from the webcam driver.

Both are using totally different library / language to access the usb camera and if the driver cannot be properly closed it may prevent it from restarting properly (and may prevent the software to close properly as well).

I have tried with the few usb cameras that I have for testing, exiting the software and restarting is possible without problems with both applications.

The fact that the software cannot exit properly may also explain why some settings / library isn’t saved when exiting.

Did you try this camera in any other software (not ours, not the original logitech tool either) ? Can you connect / disconnect the camera and restart the software without the problem ?


Thanks for your reply and attempts to recreate the problem.

I’m not entirely sure that the webcam is at fault as it works with any other app I’ve tried, basic webcam capture and the likes of Skype. However I have another which I’ll test later today… It’s a much more basic cheap one I used to use with a very old laptop before they became standard fittings.

I however have some good news… Earlier this morning I installed Netcam Studio 1.2.0 beta 2 on my Windows 10 Preview installation with the latest build 10130 and using that old webcam… it works! At least no issues with starting and stopping, recording etc. etc.

There may be a couple of small problems with the filing system, recordings not in the Gallery but have been saved in the library. Also Thumbnails are not deleted but that’s something you probably already know about.

I’ll give Windows 7 some further testing but will focus on the Windows 10 installation as the target machine isn’t running 7 - it’s Vista and isn’t to hand being 500 Km away. :smile:

Cheers, George

Just finished some more testing on Windows 7 and 10.

IT IS the webcam!! :scream: I had exactly the same issues with the Logitech Pro 4000 on my Windows 10 PC as I had with the other running 7!! I’m so VERY SORRY for wasting your time trying to replicate and resolve this problem but, in fairness, I’ve never had any issues with that webcam on either 7 or 10 until now.

To my surprise the cheap old MobileGear webcam, with its integrated microphone, works fine on both 7 and 10.

Two lessons learned…

  1. The Logitech Pro 4000 doesn’t work properly on 7 or 10 and no updated drivers are available.
  2. I need to go a get a new webcam… if you can suggest a good quality one that you know works I’d be most grateful.

While Netcam Studio is working fine there is still a scenario, when a sound activated recording is captured in the library and viewable in Windows Media Player, they are not shown in the Gallery or List of recordings. It’s a minor problem that will not prevent me using it for the application I have in mind.

Cheers, George

In some cases it can be not the camera but the fact of using an extender cable, going through a hub or just having a conflicting usb devices.

Regarding new hardware the only usb cameras i still use are Logitech Orbit AF which seems to work fine but anyway if you have possibility move away from usb camera and look forward for a network camera. Those are meant for running 24/7 can be further away from the computer and most of the time do not require any driver.

Thanks again for your response.

I did think about possible conflicts with other USB devices and also a hub getting in the way so made sure the webcam was the only device attached. I also did tests with and without an extender cable and had no problems.

Thanks for the suggestion on the webcam but that one’s more than a little beyond my budget :smile:.

I was certainly considering more classic network attached cameras but they are generally too conspicuous for the application I have in mind.

However, I did find this one at although I’m not at all sure it will be compatible. I may just order one to test that fact but I suspect the “capture device” it comes with is more than just a means of connecting cameras to the PC and will get in the way of attaching the cameras for Windows to see in the right way - if at all!

Cheers, George