NetcamStudio Android / Login failed: Timeout has occured

I’m testing NetcamStudio and it seems great.
I’ve installed it as a Windows service, with SSL certificate and configured port forwarding on my router.

The Windows Client is working well.
The Web Client, with Firefox on Windows is working well with SSL in my LAN.
The Web Client, with Chome on my Android phone is working well with SSL, in my LAN with Wifi and also in 4G through port forwarding.

But, the Android Client (on a Sony XZ1 Compact) gives “Login failed: Timeout has occured”, even over Wifi in my LAN.

Any idea ?


You have done a great job with all that!
You have pinpointed the thing that do not work. Here is the guide for the process Running Netcam Studio Server on SSL / HTTPS - Windows 7 and 10
I assume that you have used a self signed certificate for testing. Using the NCS App do not work with self signed certificate in Android. It is a problem with the Android OS. It works for some versions and for some versions not. It always work with iOS.
We worked through this for some months ago and find this discrepancy. At that time the user bought a certificate for 8 USD and then it worked.

Thank you for your feedback. I’ve generated a self signed CA certificate and a SSL Certificate matching the CA and corresponding to the DynDNS name I use.
I’ve succeeded in installing the CA certificate in Android trusted CA certificates.
Now, when I use Chrome on Android, I’ve no more warning message, https is green, like any bought certificate!
It is strange that NetcamStudio Android can’t use it… It is surely possible… Perhaps for a future version…

1 Like

What version of Android is it?

Just found interesting page :

To trust user-added CAs for Android API Level >= 24, add

<!-- Trust preinstalled CAs -->
<certificates src=“system” />
<!-- Additionally trust user added CAs -->
<certificates src=“user” />

in application Network Security Config… Would be great if you can try this in a beta version! Hope this helps…



I’ve Android 8.0.0


Thanks, I forward this!

Any news about this?

I have not set up SSL certificates. Still testing software in its native state. Behind the firewall, everything works great. Outside from the public side, nothing. I’ve set up Port Forwarding in the router to a fixed ip address behind the firewall. When I use an Android client, I get the timed out error. When I use a Windows client, I get a little more information…port unexpectedly closed. How do I determine if the closure is at the router, or at NCS? I am running NCS as a service on a win10 pro computer. Am I missing a setting in NCS, or to access from the public side, must I install a certificate?

Assuming you are not working with http/SSL.
To access NCS from the public side it is no need for a certificate. Since everything is working on the LAN side it seems to be a setup in the router.
Here is the guide on how to … Accessing Netcam Studio remotely using Web Client or Smartphone App
Only port 8100 need to be forwarded in the router.
When you test with the Android app and the public IP make sure that the smart phone do not work on LAN wifi.
When you start a browser on the Windows computer (on the public side) enter http://publicIP:8100 Is that working?
If you start the Windows client, red icon, on the computer on the public side you must forward ports 8100, 8120 and 8124.
Do you use the correct public IP to the router. Sometimes the ISP gives you a “public IP” that actually is a LAN IP to save addresses.

Thanks for the advice. I added the additional ports and made one other change to the port settings and I can now access NCS from the public side of the router. My router is a Fortigate 60D and to complete the process I needed to tweak the IP4 policy. The policy had a condition that restricted access only to http/https. The http/https restriction invoked another policy which only opened port 80/443 and it had a higher priority than the port forwarding policy. Once I removed this condition in the policy, the port forwarding worked.

1 Like