Netcamstudio X (service) and Client IOS

Hello everyone !

NetcamStudio user since 2014, I was on windows 2012 r2 and I used the remote connection without https. The Netcam server was running as a service. I have 3 foscam brand cameras (1 FI9901EP and 2 FI9961EP).

I stopped using Netcam studio for 1 year.
Today, I have everything installed on a VM in Windows 7 64. I added access to SSL with certificate. Everything works in https internally from another pc and externally from my IOS device.
I encounter some problems:
1- I can not use the server as a service anymore. the service starts normally but no longer connects with the clients.

2- I am having trouble connecting time out from the IOS application after the loggin. for example when I select “event logs”, I return to the logging screen with the message time out disconected. The rest in the app is ok I can see the library and events.

Thanks for your help


Hi Stephane,
Is it working connecting with http?
Exit the service and start NCS X. Is it working with https and the different clients?
If you recently have updated NCS the config files go back to http, unfortunately. Make sure that the config files are setup for https.
Just be sure. You login on iOS-go to event logs-after a certain amount of time you are logged out and the back to login screen.
Can you tell after how long time this logout happens?
If you use the web client on iOS instead. Do the same happens?


Hi Henrik,


1 I tested in http, putting back the original files NetcamStudioX.exe.config and NetcamStudio.service.exe.config. Netcam Studio Client connect without problem.
I pass in https by modifying the two files as indicated in your topics ssl:
add key = “WebServerCertificate” value = “Mycertificatname.pfx”
add key = “WebServerCertificatePass” value = “mypasswordpfx”
Netcam Studio Client no connection .but web connection OK and IOS with time out when i touche Library or Logs.
I guess I missed something in the NetcamStudio.client.config file
I did not understand what to change.

I have the same problem in the mobile version. I connect, I see each of my cameras, but logs and library make me return to the screen login.

conclusion I had to miss something in the config of https especially in the file client.config, but what?


NCS Windows client:
-just check that you enabled https connection on the login screen.
-since it works in web client and iOS it should be correct configured.
-the Windows client use ports 8100, 8120 and 8124. Make sure that nothing else is using these ports.
-when you start the NCS windows client is it on the same computer as NCS is running on? Don´t you get any error message?
-actually I don´t think you need to modify the client.exe.config since it is already on https.

If you are uncertain just delete the Nextcam Studio 64 folder and install NCS again.


When i start client on the same computer (or another in lan) if NCSX running as service on https , i have this popup windows ;

“Error during login: the request channel has exceeded the time limit waiting for a rest after 00:00:59. Increase the wait time value passed to the Request call or increase the SendTimeout value on Binding. The time allotted for this operation may be part of a longer waiting period.”

when i start NCSX server mode https , client on the same computer works, others in lan too .

the installation of windows is new. there is only NCSX with framework 4.7.1 and vlc.

I run my pfx and put in NetcamStudio 64 directory.

  • Web client Https on another computer OK in server mode not in service
  • Web client Https IOS same error when i use the app.

That error message was new to me, but it seems that something is missing.
Well you know, easiest is it to make a clean installation of NCS. installation program again and click on Remove
2.go to C:\ProgramData\Moonware and delete all
3.go to C:\Program Files\Netcam Studio - 64-bit and delete all. installation program again
5.make sure that everything works with this http installation; windows client, web clients, iOS app etc. the changes in the https guide in the 2 config files. Just check that the config client file have the https.

I think I have a VM with win 7 64 if I need to check after this :slight_smile:


Hello Henrick!

I found the solution ! The problem was with the installation of the Certificate. In this Topic:
Here ,
for Windows 7 , you say “Once the certificates have been Netcam Studio: Double-click on the certificate and let Windows install them. For the SSL Certificate , enter the password that was set during generation of certificates”
if you do that, windows installs the certificate in the user account and not in the computer account. And as the service turns into a computer account the certificate was not seen. I had to import it with the mmc certificate console into the Computer account. After doing this everything works in Https with NCSX in service mode.

Still the problem only with IOS and Https , (Android app is OK) either with the app or with Safari. Disconnection problems still exist when I click on Library or event Logs. .

I noticed that since a web browser like firefox it asks me to record every time my user account and the password (I did not do it at the login window of the web client) as soon as I click on Library or event logs. Maybe a track

I think there is a problem with the IOS Webkit, authentication.

Device information

Device iphone10,6
IOS 11.4
Framwork 4.5.4

NetcamStudio service

Netcam Studio Mobile 4.3.0

Thanks !

Hi there,
Thanks for the feedback I am glad you sorted it out. We always assume that people are logged into the admin account when working with these thing and then it will be installed on the computer account. However, I will clarify this in the guide. Thanks.

For a months or so ago we had a big discussion also about SSL/https and certificates and at that time IOS worked fine and Android was the problem :slight_smile: So just now we have finished going through these things again. However, thanks for the more detailed info and we check if we can recreate this on our systems.


hello here!

I update the topic. The update to IOS version 11.4.1 has fixed the disconnection errors. Now I can go to Library and Event Logs without going back to the loggin page with the connection time out error.
The problem came from IOS 11.4. All HTTPS connections work.

Have a good day !

Thanks for the update!