No Audio on Mobile devices


Running NCS 1.3.7 on Server 2008 R2. When I view the feeds from the Web interface, I correctly hear audio when its enabled. However, viewing the feeds on both the iOS app and android app, I just get vdeo, no audio. This is while being connected to the local LAN that the server is on as well as from another wireless network. Additionally, I do get sound on items recorded in the library, just not the live feeds.

Any thoughts?



I noticed the same thing (with Android, I don’t have any iOS devices) until I figured out that the default for the mobile interface is no sound. Needs to be selected after logging in to get the audio stream, just like the Windows client. The web interface is the only one that starts audio by default.


Yeah - I discovered that as my boss’s android phone (running same version of Client) working fine. We both looked at it (Same android version, same app version, etc) and got audio on one device and no others. So of 2 android devices and 2 iOS devices, we get audio on the one android and that’s it. The other 3 mobile devices have no audio.


Well, good luck with that. :wink: It works on 4 out of 4 Android devices for me. My biggest gripe is how it behaves when the screen blanks,but it’s definitely a first world problem.


Hi guys,
As you discovered this is a little bit tricky since it depends on a number of parameters like Android, iOS, version, etc. To program NCS to work for ALL alternatives and combinations would take to much processor power so therefore it is limited. The best way to get audio is to use Chrome or the native browser and connect using the Web client. In the mode jpeg/mjpeg there will be video and sound, but they use different channels and therefore not in sync. Video and audio is in sync when Live is selected. Live use h.264 and AAC and will therefore need more data and processor power to work. It will take considerable longer time compared to jpeg/mjpeg before it is rolling. If it will work depends on the speed of the network connection. Test it first with a wifi connection to the in-house LAN to be certain of the functionality.


We had successfully gotten the Android devices to work. Both are giving audio in addition to the video stream on a Galaxy S3 and a Galaxy S6. iPhone 6s and iPhone 7 continue to give only video. I will test using Chrome on iOS. Thanks.


Excellent! What do you use on the Android devices, NCS APP or Chrome/WebClient or … ?


My iPhone 7 Plus on iOS 10.2 does NOT receive audio using the Netcam Studio Mobile app (3.4.8) or the web client in Safari/Chrome on iOS. From this thread and others it seems like audio only works on Android mobile devices. Are there any plans to change this in the future? I understand that encoding multiple streams takes more processing power on the server side but I would think that there is a single audio format that works on all devices.


Hi James,
Thanks, I forward this for a closer investigation.


Our developers use iOS quite often and audio works well. However, if device is set on vibration audio will not work.


It appears that it was just the ringer mute that was the issue as I and my boss both routinely have our iOS devices muted. Ringer on = audio playback.



Excellent, thanks for reporting! Small details … :grin:

  • Henrik


Unfortunately that does not work for me. I made sure that the silent switch was off and I still get no audio through the iOS app or the web client on any iOS browser. The audio works on the server and from the web client on a desktop browser (Windows and Mac) so I know that my setup is working, just not on iOS. I updated my phone’s iOS to 10.2.1 but that didn’t change anything. When viewing the stream via the iOS app the Audio Detection overlay does not even show any activity, even when I have the exact same stream open from a desktop browser and the overly clearly shows audio activity and my computer speakers output the stream audio. Any further suggestions would be greatly appreciated.



I also just tried from my wife’s iPhone 6S running iOS 9.0.2 and she has the same problem, no audio via the iOS app or the mobile web client using Safari in iOS. Yet it does work using all other non-iOS methods that I’ve tested. This issues seems isolated to iOS.


Wait a minute… when I MUTE the audio in the iOS app (the audio button clearly shows the speaker with a circle around it and a line through it, the universal symbol for mute) then the audio actually comes through in the iOS app. Still no luck for the mobile web client using JPEG, MOTION, or MJPEG, but the fact that the iOS app works, albeit it seems in reverse function, is heartening. Thank you very much for the prompt support. I might suggest fixing the symbols in the iOS app to clarify when the audio is muted and when it is not, as it is right now the symbols in iOS are inconsistent with the symbols on all of the other platforms I’ve tried (iOS web client, desktop client, desktop web client).

Also, is there any way to keep the screen from turning off so quickly while watching a stream? It is almost as if the app itself isn’t telling iOS that it is active when a stream is up and running and as a result iOS thinks that the phone is idle, turning off the screen, closing the stream, and locking the device.

Thank you again for the continued support, NCS seems like a great product thus far, it just needs a little bit of refinement on the iOS side.



Hi James,
Thanks for your report and I am happy that it´s solved. I agree that is seems a little odd with the reverse mute symbol. I forward this together with your other suggestions.


hI I have a problem and can’t decide if it’s software or hardware related. My problem is I can’t record audio from the stream like others here. When my front camera on my Xperia Z1 is recorded on the internal memory eveverything works fine, but when I want to record the stream in to my PC via NetCam Studio there is no audio on the recordings. I was trying to conect to this adresses, or /audio and nothing helps.


What App do you use?
If you also want audio you must use rtsp://…
Http only support video.


I am using IP Webcam and correct adress is rtsp:// or plus /something?