Problem with multi view

I have a problem with the multiview when I create a new user and select some cameras. I choose 12 cameras, in the client I can see them well with the multi view, but when I select one of them to see it bigger, it brings me any other camera.
This doesn’t happen with the administrator.

Hi leagodoy!
I think I know what you mean, but I would really appreciate if you could add some pictures also.

Here I attach some screenshots. And I got something new, now when I click on one of them, the image show the message “Error in camera downloader”.
But here is the thing. I clicked on the camera that is in the first column, second row, and appear the message that I mentioned before. And then I clicked on the camera that is in the fourth column, second row and brings the last camera.

Thanks! When you click on Source, to the left side of Add source, all the cams are there and the cam number corresponds to the correct video? Also, if you have been into Settings - Source Ordering and changed it will mess up things. I tested on my system and do not see this problem. When started this? After an update or is it a new setup?
Also, with the new error something has gone wrong. Either the connection is lost or the URL is not the correct one. You run 12 cams in motion detection. Maybe the CPU is exhausted and create this problems. What is the CPU load? Check in the task manager.

For your first question, the answer is yes, eache number corresponds to the correct video. I have’t change the order in fact. I don’t know exactly when the problem started, because at the beginning everyone used the same user but then, someone asked me if I can generate him a user with specific cameras (12) and when I did it, and choose the 3x4 view and try to bring one to fhe front by clicking on it, I discovered the problem. Also, I checked in single view (when you select one cam from Source) and it shows the correct camera. And finally I detected that the “Error in camera downloader” is from one cam that I disconnected.
About the CPU, you mean locally in my PC or in the server? And the 12 cameras are not in motion detection, just some of them.
Thank you for your support.

I’ve got 31 cameras and 6 of them are in motion detection. I cheked the CPU load and it’s at 90% approx.

OK, fine! Good you the source for the error. Sometimes when the CPU load is too high this no video can happen.
I have access to a system with 15 cams, all in motion detection and a CPU load of 95% so I cannot add more cameras. I created a user with access to only one cam 12 and it worked. However, can you recreate this problem with cam 0 to cam 14 in your system? If you can I will do the same here and see what´s happening.

I set a user called “prueba” that means test in English, and choose the cameras 0 to 14, and I couldn’t recreate the problem. How can we continue?

I have to forward this to our developers to continue to look into.

I’m not sure to have the exact steps on how to reproduce this.

Did you manage to reproduce @Henrik?

No, I could not reproduce this. I would say that something went wrong in the setup process.

I’d like to know if it’s possible to see this remotely. I need to fix this asap. Thank you.

OK! Install Teamviewer from It is program for remote control of computers. Install that and you will have an ID and a password for your computer. I will send you a PM where we can exchange these details.

I’ve just re installed NCS, a clean instalation, (I haven’t loaded the library yet) but I generated the users and I’m still having the same error. Please, I need to solve this.

Clean installation = you also removed the files in the ProgramData - Moonnware library?
I recommended you to add the cams and have a check on when the problem started. In my installation I have 15 cams with no problems and for some days ago I had access to an installation with 31 cams and several accounts with no problems. So at which point did the problem started in your installation?


Exactly, I remove the files in the ProgramData and also in the regedit. I don’t know how to check on when the problem starts. There must be another way to figure where the problem is.

That was my suggestion so do you have another one? Eveything is fine for the admin account. Remove all the user accounts and check if it works. Add another user account and check etc. Finally, it must go wrong somewhere.

Henrik, I misunderstood you. I’ve just realized that you mean to add one by one the cams to the user account instead to the server again to find out where the problem is. Now I’m doing that.