Setup 1.9.1 crashes on Startup

I am trying to update Netcamstudio Server X from 1.7.2 to 1.9.1. The setup program crashes immediately after starting. I see shortly any small window without any error message. I looked for the logs and did not find anything. Can you help me?

Windows Server 2012 R2 with all last updates
.NET Framework 4.8 installed
Visual C++ Redistributables (x64) installed too

So far so good with the necessary programs. Going from version 1.7 to 1.9 is a big step and a lot has happened with the software, but the installer should always run. Somehow it seems that something is blocking the installer to start. First I assume that you have downloaded a new version from the website to avoid if that is a problem. Downloaded should be the 64-bit version. Is there any antivirus program running that can block startup? The account from where you install must have Admin rights.
For some reason this have caused problems for some users (if they exists):
-go to C:\Users\henrik\AppData\Local\Moonware and delete all. Change henrik to your account.
-go to C:\Users\henrik\AppData\Roaming\Moonware and delete all. Change henrik to your account.


Hello Henrik,
Thanks for your answer

  1. I starts setup as administrator
  2. I have no antivirus on this PC
  3. I try start setup from downloaded version from the website and with update button in a Netcam Studio X GUI.
  4. i remove both orders in AppData
    Unfortunately, none of the above helped. In this little window i can see: “Extracting the main application files” :((

Is NCS 1.7.2 still installed and works?
Can you start the installstion program for version 1.7.2? If so click on Remove and do the process for clean installation. How to make a clean installation of Netcam Studio
Can you start uninstall from Control panel - Programs and features?

NCS 1.7.2 works good and uninstall program starts too from control panel.
i cant remove it now, my boss needs cameras, he watches how carefully we wash our hands at work )))
I will try a clean install in the evening and let you know if it works or not.

Sounds like a good strategy :blush:
Before you start, copy the folder in ProgramData/Moonware … to a safe place. Same with 1.7.2 installstion program.

Hello Henrik,

  1. I made a snapshot of my windows 2012 R3 Server
  2. saved ProgramData/Moonware folder
  3. deleted the old NCS 1.7.2
  4. restarted the windows server
  5. launched the installation of a NCS X 1.9.1 setup
    is the same problem.
    if there are no installation program logs, then probably the only thing that remains is to install a new windows server and test on it

P.S. Excuse my French :smile:

%#&/&¤ … He he.
Since this is handled by Windows any logs must be in Windows Event Viewer - Windows logs - Applications. Look for Errors there.
Download some other exe-program from Internet and try to install that.
After deletion of 1.7.2 can you start installation program for 1.7.2 and install it again?

I dont have installation program for 1.7.2. I returned to last server snapshot.
7zip setup works fine…

I too have had the same problem for awhile now.

For some reason any version from 1.8.0 on will no longer install on my dedicated computer I use for my security and other CPU intense tasks. When I double click on the installer it quickly opens a small launcher window and then closes in the blink of an eye and it never opens the setup wizard. I have tried running it as admin and selected compatibility modes and many other ways and the same thing happens.

I am running Win 7 Pro as it is required for the other work I use that computer for. Last night I decided to do a fresh format and install of Win 7 and install all the latest drivers for all hardware and updated windows to all available updates. I still could not get the installer for any version from 1.8.0 and up to work. If I use it installs no problem.

My computer is custom built with an ASUS ROG Rampage VI Apex motherboard with 16 GB Kingston Ram. i7 7820x CPU. A Radeon R9 200 Series GPU.

My temp solution was to install the newest version on my older slower computer that is also running Win 7 Pro with all updates. Then I copied the “Netcam Studio - 64-bit” folder from the slower computer to the main computer along with the ProgramData Moonware folder and the start menu icons. It actually works that way but I would like to get it installed from the installer because I imagine things in the REG or other system32 files may be missing. Could someone please help? Thanks…

PS… I did look at event logs and nothing in any of them.

i extract the setup file to Desktop with this key: ncs-inst-x64.exe /extract <…Desktop/ncs>
and run the setup from this folder. Its work for me… <…Desktop/ncs> - is any Folder on your PC.


Hi Alexander,
Thanks for the response. I think we would appreciate a little bit more detailed description for users not so used to command lines :wink:

Why should I work on your side of the street? :smiley: :rofl:

  1. Copy the NetCam Studio install file ncs-inst-x64.exe to your Desktop
  2. You starts cmd.exe (Win+R) -> cmd.exe , type: cd Desktop and press Enter
  3. Type: ncs-inst-x64.exe /extract and press Enter
  4. After extraction you have following Folder on your Desktop
  5. Go to this Folder and click NetcamStudio_64.exe
  6. Finish
1 Like

Hi Alexander,
Thanks a lot for your extra effort to help another user @Comtek in the community!
I hope it solves his problem.

Thanks for the help… I had tried to unpack with 7zip before but I guess it does not unpack it the same way. I will give this a try and see what happens and let you know.