V380 stream url

Sorry, but is it really a good value if you cant make it work?

The camera works properly with the V380 app but I would like to use the Tinycam monitor app and I don’t know how to set it.

Sorry if I insist but the camera works well (with the V380 app) and the image is also of good quality, both day and night.
I would only like to use it with the TinyCam Monitor app (where I have already configured other ip cameras).
I took a picture of the disassembled camera.

I have buy this camera in Aliexpress:


System app version: AppV380E12_PCARD_V50_V2.5.6.4_20181123

System kernel version KerV380E12_PCARD_V50_V2.2.0_20160506

System firmware version:


I also looked at the packets with wireshark and saw that the camera connects to a china server with port 8800 through which it sends the video stream.

I’d like to find a different firmware but I can’t find it

Thanks for Help

i am using V380 exe downloaded from www.av380.cn and it working on my home pc and i can watch my all connected camera. But when i try to login in my Office’s PC it shows network connection error , and even when i tried without login then camera shows offline, while same camera is working on my mobile phone.
May be this is the issue due to firewall in my office .
So what Should is do
Please help me ?

i am using V380 exe downloaded from www.av380.cn and it working on my home pc and i can watch my all connected camera. But when i try to login in my Office’s PC it shows network connection error , and even when i tried without login then camera shows offline, while same camera is working on my mobile phone.
May be this is the issue due to firewall in my office .
So what Should is do
Please help me ?

i have one more issue with this
when i am using my home PC and give nick name to connected camera and use same login details with another pc for same Application v380 on windows PC then i can find camera but nick name become empty. Any suggestion how to hold nick name for same login details and different devices.

This IP camera is a copy of the Digoo DG‑M1Q, I bought one too,This is my one from ebay… https://www.ebay.co.uk/itm/Mini-Wireless-1080P-HD-WIFI-IP-Camera-Smart-Home-Security-Camera-Night-Vision-UK/383026186593
Manual… https://images-na.ssl-images-amazon.com/images/I/911KXTAx2XL.pdf
System firmware version:
HwV380E12_WF3_PCARD_V50_20160217 only work with the V380 app on phone or on PC.yes I downloaded there app for the PC from there website here… https://v380-camera.com or here http://www.av380.cn/Gjh2.htm

And this is the real one from ebay,you can see the difference in price… https://www.ebay.co.uk/itm/DG-M1Q-960P-2-8mm-Wireless-Mini-WIFI-Night-Vision-Smart-Home-Security-IP-Camera/253673743349
They look identical only thing is the price,Copy £10.98 original £36.83 both are from China.

Here is its ports info that V830.exe connects to…

I just got mine working with Ispy so it should work with Netcam Studio, I am using the VLC plugin in Ispy to show the feed. I can’t use NS cause I have 4 cameras and NS only allows 2 free,you can have as many as you like in Ispy for free.

This is what I did…
Create a file called ceshi.ini in root directory of a micro sd card containing this below,
make a .txt file and change its .txt to .ini and name it ceshi then put this in it and save it
Put it in the root the Micro SD Card,so with nothing on it and in Fat32.
I used a Kingston 32gb micro sd card.
Turn camera off, insert the micro sd card, boot camera, wait a while, turn camera off, remove sd card, boot camera.

After I had done that, the camera updated and RTSP port was now open.
This is the url I used “rtsp://xxxx:xxxx@192.168.0.xx/live/ch00_1”
you can put that url in to FFMPG(H264) in Ispy and it works too.

I have baught two different pan tilt V380 cameras from e-bay.
I can watch both on my smartphone
However on my pc (win 10 app MVCMS) I can watch only one of the them. The second one, while it seems to be connected it appears no immage. Instead it shows the indication (-2).
Any help?
Is there something I can do?


I am having a problem with my camera ip v380 smart net camera.

I can get the image on the v380 software on my phone as well as on the windows version.

but nothing works when I try with rtsp address on vlc or other.

Do you have to do a special manipulation?

Thank you !! (Sorry for my english)

Have you tried the windows app here (http://www.av380.cn/Gjh2.htm) or is it the same version…?

Download this file (ceshi.ini)(https://1drv.ms/u/s!AsiWKsjhQ2jegp4cGv3341A9Jlv5kA?e=wHZJCf) and put it on a empty sd card or root of sd card and turn off camera then put sd card in camera,now turn on camera and wait ,you should here something seid in chinese between its say “System Starting” and “connecting to wifi”, wait for about 5 minutes then turn off camera take out sd card and then turn it back on and use this url to connect to it Via Netcam Studio or Ispy "rtsp://user:pass@IPADDRESS/live/ch00_1” its worked first time for me. User Pass is the user and password you set in the V380 app for the camera. Example url… “rtsp://admin:hello@” if the url sill don’t work try changing the channel to 0 so at the end of the url “ch00_0”.you can try different numbers at the end.


thanks a lot for your help. I followed your advice and did all the steps in order, I heard the voice in Chinese but it still does not work when I start the stream on VLC.

When I go to this address I get that :


You don’t use 8899,only that url,it should work,It work with another IPcamera I just bought too.

Danke für den Tip mit der Datei ceshi.ini
Hat super funktioniert

Thanks for the tip with the file ceshi.ini
It worked great

For people with firmware:
Software version: AppV380E11_EXIOPTZ_ETH_V2.5.4.0_20180611
Firmware version: HwV380E11_WF3_EXIOPTZ_ETH_20160217

After update it will be:
Software version: AppV380E11_EXIOPTZ_ETH_V2.5.9.5_20180611
Firmware version: HwV380E11_WF3_EXIOPTZ_ETH_20160217

The update file from links above didn’t work for me, so i contacted the support team at v380technical@gmail.com they provided me with an update file:
AK3918E-V200_V. .zip

extract and copy files to root of the memory card, insert the card in the camera, you will hear update complete after 2-3 minutes, remove the memory card and create the “ceshi.ini” file as mentioned above in this thread.

After that i can see the rtsp stream, the problem is i can see it without even entering the ID and Password :laughing:
And the other problem is i can only see video, no audio.

Now i’m wondering if there is any trick to update the time and date of the camera automatically after starting the camera, something like the ceshi.ini file.

Thank you for this post. This did the trick for me as well.
Firmware version:
In installed the ceshi.ini in the root dir of an SD card, switched off the camera, put the sd card in the camera and switched it on again. My camera gives voice messages to tell what it is doing. Some of the messages where suddenly followed by chinese messages. After booting, I let it on for a little while (5 min) (maybe it had to download new firmware or so, although I don’t think it did), and then switched it of again and removed the sd card. Then I rebooted. The chinese messages were gone now, just plain english, as before. A port scan (using masscan on linux) revealed that now the following ports are available: 8899, 554 and 8000. Port 554 is rtsp and I managed to get it working in VLC media player (open network stream, using the url that you mentioned in your post.

Hi all!
Thank you so much for your contributions. I managed to see the video through the /live/ch00_1 url. Ports 8899, 554 and 8800 are open but, there’s no audio!.. I’ve tried everything, any clue about how to get the audio too?
Also, port 23 is closed… do you know how to open it for telnet and maybe get more info?

Any help is much appreciated.


Good morning, since I updated the versions of the internal software of the cameras, the quality of the video was very low, did someone happen to it and could I solve it?
the image has a lot of noise, and the night vision impossible to walk. nothing is seen

Me pasa lo mismo el video cuando las compré era muy bueno y ahora es terrible la calidad voy a subir una foto