Google Drive uploader fails


#1

Using latest version 1.6.1.0

Have set up to sync with Google Drive and seems to keep failing as shown in this log entry


Information 15:29:16.210 Source(1).StartRecording Started File Recording [MotionDetector]. Took 0 ms 865 555.86MB
Information 15:29:26.477 Source(1).StopRecording File recording completed for Recording_0_20171010_152916_205.mp4 (00:00:10.2630000). Took 63 ms 875 414.60MB
Information 15:30:14.619 SyncNetwork Starting upload (Y:\NetCam)… 848 548.78MB
Information 15:30:19.068 SyncNetwork 1 items uploaded successfully. 851 548.66MB
Information 15:30:19.075 SyncNetwork Disconnecting from NAS / Network (Y:\NetCam) 851 548.66MB
Information 15:30:19.082 LibraryManager.Sync Synchronized 1/1 Items using SyncNetwork. 859 554.60MB
Error 15:32:02.548 SyncGoogleDrive Google Drive Uploader: Error in UploadItem
Exception Detail:One or more errors occurred. 851 559.93MB
Information 15:32:02.549 LibraryManager.Sync Synchronized 1/1 Items using SyncGoogleDrive. 851 559.93MB


Sadly there doesn’t seem to be any further exception info. Also, the file (?) sizes mentioned seem odd - the file this related to was actually a 24MB mp4.

Connection was established ok and a root folder was created at “NetCam Studio / Motion / 20171010 / 15” but no file was uploaded as per error

Is there a fix for this - seems that there has been no new release for over 2 years and GD may have changed the API in that time ?


#2

Hi,
Just connected to GD and it works very fine


looking in GD and all files are there and can be played.
“no new release for over 2 years”, no new release of what?
Are the files created and playable in NCS Library? If that works it got to be something that stops the file from uploading to GD. I am using default settings for everythings and that worked. Are you running NCS X or NCS as a Service?
You can find a better loginfo in the folder ProgramData - Moonware - …

-Henrik


#3

“no new release for over 2 years”, no new release of what?
Change Log posting with 1.6.1.0 mentioned is dated Feb 15 so assumed was issued then

Are the files created and playable in NCS Library? If that works it got to be something that stops the file from uploading to GD.
Yes - files shown in NCS X client

I am using default settings for everythings and that worked.
put user name / password in and that was all - logged in and has created folders in GD and button shows “Logout”

Are you running NCS X or NCS as a Service?
NCS X on client window - running as service - 64bit Win7

You can find a better loginfo in the folder ProgramData - Moonware - …
That was where that log snippet was copied from …
C:\ProgramData\Moonware\Netcam Studio\Server\Logs

Here is another test just now - this time the local network sync turned off so only GD active


Information 23:45:54.057 MoonwareCore.SaveSettings Settings Saved 1008 600.54MB
Information 23:58:16.669 Source(1).StartRecording Started File Recording [MotionDetector]. Took 0 ms 997 616.13MB
Information 23:58:27.592 Source(1).StopRecording File recording completed for Recording_0_20171010_235816_669.mp4 (00:00:10.9228616). Took 31 ms 1000 473.70MB
Error 00:01:02.058 SyncGoogleDrive Google Drive Uploader: Error in UploadItem
Exception Detail:One or more errors occurred. 1021 615.50MB
Information 00:01:02.058 LibraryManager.Sync Synchronized 1/1 Items using SyncGoogleDrive. 1021 615.50MB


As you can see, no details on the error - no entries in Event logs either. Maybe the message is from Google for some reason.

GD shows Netcam Studio as an App and offers the option “Disconnect from drive” so connected ok. Can’t see any other settings / permissions to play with ?


#4

Hi,
Three things.
1.Run NCS X with the interface as shown in my picture above. Not the service version.
2.Any setting in GD that do not allow upload of mp4?
3.Google have an enhanced security for login. Is that the problem? It can turned off.
-Henrik


#5

Hi,

  1. Sorry - misinformation from me - that is the interface I’m using - my mentioning client confused things. Probably not worth trying the “real” client program since your’s works ok with the X interface

2/3. I will see what more I can find out about GD - mp4 is common so can’t see them blocking that. It is a new account but has synced ok with local PC so is active. Will also have a look at the enhanced security but didn’t set anything special like 2 factor - just simple login, Does feel like the problem is at the Google end though rather than NCS,

The internet connection here is exceeding slow at around 2Mbps so files would take a long time to upload - relevant ?

Another thing just seen on GD - the folders were created to receive the file on the last test but following the failure GD reports “Motion”, “20171010” and “23” were all permanently deleted - presumably intelligent action by GD as a result of the failed upload to the created path to avoid dangling folders.


#6

Hi,
Check this one in Google, Third Party Access. One issue should be NCS.


Upload Speed should not be a problem, but start with a small file.
-Henrik


#7

Hi Henrik

Still no joy. NCS has access to GD allowed under Third Party Apps and also shows in the security review you mentioned …

Enabled the “less secure apps” setting (was off) - stopped NCS having logged out of GD and disabled GD sync - restarted, logged in to GD in NCS then enabled sync, Same problem !

Did monitor one session with Wireshark but didn’t see anything useful (to me) since is done under SSL. Packets and ACKs and FIN ACKs look ok.

Think it Is either permissions issue for NCS or something different with API - I’m in UK so uses Western Europe Google servers which may be different to you. Are you using 64bit/Win7 - trying to identify what be different in our setups.


#8

I´m in Sweden and using Win10 Pro. I just tested on win7/64bit with good results.
-test with another computer.
-the classical, do a new clean installation of NCS 1.6.2 Netcam Studio 1.6.2 and remove everything insidde ProgramData-Moonware. If you have files in the Library they can be left there.
-search in this forum for google drive and there are some postings. Maybe there are some good info there.

-Henrik


#9

Doh - I have 1.6.1 (as in OP) - updated to 1.6.2 but no different after various restart tests :confused:

Retested with “allow less secure apps” - still fails on 1.6.2

I noticed on the link page for 1.6.2 when you scroll down a comment “Google Drive uploader fails” - maybe relevant - looks like a known issue of some sort - maybe not fixed ?


#10

The “Google Drive uploader fails” is your post. Click on it and you will end here.
As I showed it works well for me in win10 and win7.
Sorry, no more ideas.
-Henrik