Netcam Studio X Auto Start using Task Scheduler


#1

I have NETCAM STUDIO 1.6.1 set to start in SERVICES as AUTOMATIC however everytime WINDOWS 10 reboots I have to go into services and start the service. Also Is there a difference between AUTOMATIC and AUTOMATIC delayed start?


#2

Hi,
It turns out that if the computer is a little bit slow it will work much better if you set NCS Service to Automatic delayed start. It might also be that the later versions of windows are a little bit more demanding so windows just ignores services that it do not like. I have one of that kind myself. If on automatic all windows services etc will start at once and sometimes that will choke the computer. So let all necessary windows services start first and then NCS will do its entrance a couple of seconds later. I know this was not the case before so we should look into what happened @Steve
-Henrik


#3

It could be that it fails starting in case it depends on another service but in this case we need the logs of a failed startup so that we can check what’s wrong.


#4

I have had this problem from the beginning. I’ve tried Automatic, Automatic Delayed. I’m about to give up on the service, since that part just cannot cooperate with Windows 10, and I blame Windows. Netcam is not buggy software! Windows 10, however, I’ve found to be a mixed bag. Will be changing to the non-service option until further workarounds to fix the service surface.


#5

Is there a setting for autostarting the server with Windows? I am not finding it…


#6

Hi Jimmy,
I have noticed this also and Automatic Delayed Start will not help either. Since I have some systems to compare I have noticed that the problem for me ocurr when I have a slow processor that must start all Windows processes and finally NCS. It seems there is a timeout and after a certain time no more processes will be started. I am not sure about that … What CPU do you have and how many cams do you use in NCS?

NCS X Server have no built in settings for auto start. You can easily autostart by putting a shortcut to NCS in this Windows 10 folder C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

Good luck,
-Henrik


#7

I don’t know how it’s possible, but putting the shortcut in Windows’ startup folder doesn’t even work. I have two other programs autostarting successfully in that folder. And when I use the shortcut from that folder to manually start it, it works. But it seems the software has decided that it will not cooperate with all attempts to automatically start! What gives??


#8

Hi Jim,
Yes, I think I know why. Windows 10 is very picky when it comes to start exe program so putting a shortcut of NCSX in the Startup folder did not work for me either. Searching on this gives this also.

However, I found another way that works for me.
Use the Task Scheduler and generate a task to start NCS X. If the Task should run at startup of Windows you must provide a password for that account. Since I do not have password for the admin account I created a Task that starts at Login instead. When I start or restart Windowss it auto logins to my admin account and now also autostart NCS X.
The slider in the User Account Control Settings must be at the bottom or one level up. It cannot be set so that an applications asks for permission to run.

You are running Win10, but what processor and RAM do you have? I think we need to have a look why NCS Service do not start even in the delayed setting.

Good luck,
Henrik


#9

Why do I have dozens of apps on my Windows 10 machine which have a standard setting for “Start with Windows” or “Start at Windows Login”, except for my security cam software, which makes me jump through ridiculous hoops, and still won’t autostart? Autostart isn’t a paid feature, is it? Because I would pay for that…


#10

Well, nothing wrong with the processor. I am running win 10 Pro and I am not sure if that is different from win 10 for Task Scheduler?

After you have created the Task you can see it here:

In the General Properties of the Task I have these settings

and of cause the slider in the User Account Control Settings must be at the bottom or one level up

When I logout and logon again NCSX starts. Also at a Restart after the Logon NCSX starts.

-Henrik