Recording to password protected NAS


#1

Hello. I’m trying to record to a password protected NAS. How do I enter the username and password under the “library settings” box? The path to the drive and folder is, “\ROBERTS-NAS\Cameras\Recordings\Recordings”

When I added a password requirement to the NAS it obviously stopped recording because I’m not sure how to tell NCS to login. Thanks!


#2

Hi!
I am running a system like that myself and there are two ways doing that. If running NCS X you log in to the NAS from Windows Explorer and save the credentials. When running NCS X it uses the saved login. This is managed under user credentials.
If running NCS Service it is a little bit more complicated, but get back if you will do that.


#3

This isn’t working for me. I can access the network drive from explorer but NCS won’t record.


#4

I’m running netcam studio x


#5

Its looks like this for me. Click on 1 and when you click on 2 it should ask for login if not saved before. Click OK and you should have 3.

Maybe it is missing \\ before ROBERTS-NAS
Also make sure that you run NCS X as Administrator.
Do the user account have write permission to that folder on the NAS?


#6

Hi Henrik. I followed your instructions and got the prompt for username and password. I entered it, clicked save credentials, and it recorded as expected. The issue now is that after a computer reboot it seems the credentials are not being remembered because I have to enter them again through settings in order to record again.


#7

Go to Control Panel and then Credentials Manager. Look under the tab for Windows Credential if you have it there the first time. Make a reboot and go to the same place and see if the credentials are there or gone. I assume you checked the checkbox for saving also when login the first time. You are running under account that have admin rights. After a reboot going to the Network in Windows Explorer and go to the NAS, do you need to login again?
-Henrik


#8

Ah. This was the issue. The wrong credentials were stored!! Thanks for your help.


#9

Hehe, small detail but sort of important!
Happy it works now!
Henrik