V380 stream url


#1

Bought a generic IP Camera (Picture attached, Amazon Link). Though in the product page it mentioned as some company name, from the box it appears that this is a generic, hence no documentation, no support.

Android App used V380.
In AP mode, it connected and work from mobile (using V380 app).
It can not connect to hidden wifi network. (This is just for future reference)
Camera connected through ethernet, mobile and computer (windows 10) are also connected to the same LAN.
Camera works perfectly from V380 app.

Now in computer:
I tried to get using NVCMS_LITE (MVCMS_Lite.exe, after installing VideoCodec.exe), the device manager never detects the camera, neither manual addition works (shows: please check whether XServer service been opened at front server or not)

From this link I tried:
rtsp://user:pass@ipOfCam/live/ch00_1
rtsp://ipOfCam/live/ch00_1
not workd.

Downloaded ONVIF Device Manager v2.2.250
Supprisingly detects camera ip automatically. However, live video, video streaming not worked. Though, PTZ control WORKED.

In netcamstudio, this camera not listed (as this has no specific company name, though the model is very popular in Online Indian market)

Info using Fing app:
camera uses port 5050, mmcc multimedia conference control tool

Info using V380(5.9.2) app:
system app version: AppV380E11_EXIOPTZ_ETH_V2.5.0.6_20170927
system kernel version: KerV380E11_EXIOPTZ_ETH_V2.1.0_20160506
system firmware version: HwV380E11_EXIOPTZ_ETH_20160217

Please help for finding PTZ control commands and videos streaming url.


#2

Sorry, but that’s how it is with these cameras. I don’t see ONVIF so that’s out. Port 5050 is a special port that is used for as you write multimedia applications. To connect using rtsp port 554 need to be open. You can search in this forum for v380 and see what other people have tried.
To have this camera work for PTZ, video and audio it must support ONVIF.

EDIT:
If it opens in ONVIF Device Manager take this URL
image

and put that URL in the tab for ONVIF Source in NCS for manually. Add logins and see what you get.

-Henrik


Fentac V380 Connection
#3

ONVIF manager I have:
Capture
Identification to certificates all shows: "Method β€˜GetScopes’ not implemented: method name or namespace not recognized."
Relays shows:
The remote server returned an unexpected response: (400) Bad Request.
Webpage shows:

<?xml version="1.0" encoding="UTF-8"?>

<SOAP-ENV:Envelope xmlns:SOAP-ENV=β€œhttp://www.w3.org/2003/05/soap-envelope” xmlns:SOAP-ENC=β€œhttp://www.w3.org/2003/05/soap-encoding” xmlns:xsi=β€œhttp://www.w3.org/2001/XMLSchema-instance” xmlns:xsd=β€œhttp://www.w3.org/2001/XMLSchema” xmlns:wsa=β€œhttp://schemas.xmlsoap.org/ws/2004/08/addressing” xmlns:wsdd=β€œhttp://schemas.xmlsoap.org/ws/2005/04/discovery” xmlns:chan=β€œhttp://schemas.microsoft.com/ws/2005/02/duplex” xmlns:wsa5=β€œhttp://www.w3.org/2005/08/addressing” xmlns:c14n=β€œhttp://www.w3.org/2001/10/xml-exc-c14n#” xmlns:wsu=β€œhttp://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd” xmlns:xenc=β€œhttp://www.w3.org/2001/04/xmlenc#” xmlns:wsc=β€œhttp://schemas.xmlsoap.org/ws/2005/02/sc” xmlns:ds=β€œhttp://www.w3.org/2000/09/xmldsig#” xmlns:wsse=β€œhttp://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd” xmlns:xmime=β€œhttp://tempuri.org/xmime.xsd” xmlns:xop=β€œhttp://www.w3.org/2004/08/xop/include” xmlns:tt=β€œhttp://www.onvif.org/ver10/schema” xmlns:tds=β€œhttp://www.onvif.org/ver10/device/wsdl” xmlns:tev=β€œhttp://www.onvif.org/ver10/events/wsdl” xmlns:wsnt=β€œhttp://docs.oasis-open.org/wsn/b-2” xmlns:timg=β€œhttp://www.onvif.org/ver20/imaging/wsdl” xmlns:tmd=β€œhttp://www.onvif.org/ver10/deviceIO/wsdl” xmlns:tptz=β€œhttp://www.onvif.org/ver20/ptz/wsdl” xmlns:trc=β€œhttp://www.onvif.org/ver10/recording/wsdl” xmlns:trt=β€œhttp://www.onvif.org/ver10/media/wsdl”>SOAP-ENV:Bodytds:GetDeviceInformationResponsetds:ManufacturerIPCAM</tds:Manufacturer>tds:ModelIPCAM</tds:Model>tds:FirmwareVersionHS-Camera_No1</tds:FirmwareVersion>tds:SerialNumber4c9601cee3bc</tds:SerialNumber>tds:HardwareId000255b4-55b4-76bd-b4bd-4c9601cee3bc</tds:HardwareId></tds:GetDeviceInformationResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>

In ONVIF, the only working part is Pan&Tilt, i.e., movement of camera. No zoom, stream appears.

Wireshark gives nothing on rstp for computer to ipCam.
Packet Capture gives nothing on rstp/authentication for andriod to ipCam.
gives nothing means all are encrypted data no useful information in plain text.

I also tried:
rtsp://ipAddr//live/ch00_1
rtsp://admin:password@ipAddr:554/
rtsp://admin:password@ipAddr:554/camID
rtsp://admin:password@ipAddr/user=admin&password=password&channel=1&stream=0.sdp?
rtsp://admin:password@ipAddr/channel=1&stream=0.sdp?
rtsp://ipAddr/user=admin&password=password&channel=1&stream=0.sdp?
rtsp://ipAddr:password@ipAddr:554/camID
rtsp://ipAddr:554/ch0_0.h264
rtsp://ipAddr:5050/ch0_0.h264

port scanner shows port no 8899,8800,7050,5051,5050,5040 are open


#4

For the V380 I use FFMPEG(H264) in iSpy with rtsp://192.168.x.x/live/ch00_0
For the V380E with ptz I use rtsp://admin:password@192.168.x.x/live/ch00_0
with admin/password being the actual login credentials for the camera.

I guess the login doesn’t matter. I never manage to get the ptz or mic/speaker working so I use
the iPhone app to control and use those.

/Ubbe


#5

source code of v380: apphttps://github.com/brusdev/V380-SDK
@ubbe thanks for additional urls, however not worked. :disappointed_relieved::triumph:


#6

The camera with multimedia port 5050 do exactly what it says to do. If you want it to do something else, well as long as port 554 is closed you will never get this to work with rtsp and neither with NCS. If you must use this camera look for a new firmware. It’s been discussion in this forum about that and search the Internet.


#7

Yes, I’m also thinking about this. To get right firmware, I need to open the hardware probably…


#8

The version I have in V380 ptz that works with rtsp are
KerV380E2_PTZ_V2.10
AppV380E2_PTZ_V2.4.2.1
HwV380E2_WF1_PTZ

There is a device upgrade function in the V380 app for iPhone and after a few weeks that I used the camera there was an upgrade available. I did that upgrade and the camera stopped working in iSpy. I had to change the configuration to the rtsp://admin:password@192.168.x.x/live/ch00_0 one. It was a totally different configuration I used before that but do not remember it now.

You probably have to look in the iPhone app to see what ip adress it contacts for upgrades and how it verifies firmware versions.

/Ubbe


#9

Check here

-Henrik


#10
  1. My board is based on Ankya AK3918 processor.
  2. The link is dead (removed by admin)
  3. There is board with same processor BPI-D1 (BananaPi) except the Ethernet port.