VLC 2.2.0 and Netcam Studio


#1

If after installing VLC 2.2.0 (or Netcam Studio) you are receiving errors in LibVLC similar to:

The procedure entry point vlc_fastmem_register, aout_channelsrestart, pl_getcould could not be located in the dynamic link library.

We have been facing this error as well on our test systems (windows 7 and windows 8) right after upgrading VLC from 2.1.5 to 2.2.0.

There is an easy way to solve the problem:

  • Uninstall all versions of VLC from the computer
  • Ensure there are no files left in C:\Program Files\VideoLAN\VLC and C:\Program Files
    (x86)\VideoLAN\VLC
  • Perform a clean installation of VLC 2.2.0

We currently have no details about the reason of this issue. We suppose that some plugins which are not compatible with VLC 2.2.0 are left in the installation folder when selecting the upgrade option. If you have more information about this problem, feel free to share.