Android Client and HTTPS/SSL


I’m using Netcamstudio (latest versions for Server and Clients) for quite a while now.

I activated SSL on the server and I can access it from every PC via Windows Client or browser.
The only client which doesn’t work is the Android client.
When I use a normal browser in Android it works fine.
I used a self signed certificate but I added the Certificate Authority certificate in Android so I get a “green” connection indication in Android Chrome.
But when I use the Android client, after some seconds I get the message "login failed. Timeout…"
When I disable HTTPS/SSL on the server the Android client works fine.

I’m doing this all locally, so no router involved.
Any idea?


Hi Erik,
Yes you are correct. I am quite certain I did this some time ago with an earlier version of the app and it worked, but we have seen that it do not work in this version and we are looking into what might be the problem. There are already som postings about this. So I hope it will be solved sooooooon :slight_smile:

I am little curious about “added the Certificate Authority certificate in Android …” If you have the time I would very much like to know a little bit more about that and how you did it, if possible.


Hi Erik.
It works with iOS so it might be something with Android that blocks self signed certificates. We are looking into it.

Hi Henrik,

sorry for the late reply.
Good news that you’re looking into it.
Usually email programs in Android have a setting to allow any certificate when you connect to an Exchange server.
So there must be a way somehow.

About the CA
I used a Windows Server OS to create the certificate.
Then I simply double clicked on the exported CA .cer in Android.
After this the CA certificate appeared in the user section of the Security Certificates in Android and when I access any website on my server at home they are indicated in “green” in Chrome…including the Netcamstudio webserver.


1 Like

After investigations it turns out that Android refuse self signed certificates for security reasons. With iOS it works, but not with Android.