Artifacts surrounding motion (streaming and recording)

Hi all;

I’m experiencing visual artifacts surrounding motion intermittently on one of my more active cameras. I only witness it during the stream (RTSP UDP or TCP over jpeg/mpeg) or during the NCS recordings. I’ve tweaked all the buffering and variables in an effort to isolate the problem and fix, but it persists. I have even tried swapping out the camera, but it continues. When I view the camera directly on the built-in webpage of the IP camera itself, this does not occur. I’m running Windows 10, 8 cores, and lots of RAM over a wired gigabit network storing to a high I/O NVMe drive. Latest version of NCS.

Welcome any thoughts or if others have experienced this. (PS: this is a repost as my original disappeared)

What camera is it (brand and model)? How is it connected to NCS (predefined template, Custom URL, …)
Please, post a picture since it will help understanding much better what you experience.
Do you have these artifacts also in the live view in NCS or is it only in the recordings?
These things usually occur when the data stream from the camera cannot be decoded correct. Standard is to move to rtsp_tcp, but that do not help? The data stream (bit rate) or fps from the camera can be to low. If the camera runs on wifi this can be the case. Check also the configuration in the camera and increase bit rate or any other parameter that increase the data stream.


Thanks Henrik, I’ve witnessing it using generated code as a webpage served up by NCS. I see the artificating within the NCS app live view, on the webpage output and in the recordings. I just cleared my recordings but I’ll post an actual example when it occurs next. (if it occurs next, I just took your advice and maximized the stream bitrate) I’m using RTSP_TCP in the NCS settings and that did not solve the issue. Attached are the cam settings I am currently trying per your advice.


Video Coding h264 highprofile: change that to something else like base or something.

Ok, I’ll do that, and since changing the bitrate too, I’ve not witnessed it occuring! fingers crossed. Thanks Henrik!


Here are my encoding/decoding and recording settings in case anything jumps out :smile:




1 Like

Here’s an example of recorded playback, it seems worse now.

Maybe it is time to reinstall and start over. Everything worked fine at the beginning.

Most of the setting above are extreme and the computer cannot handle that. Recommend default settings to start with. For decoding move to hardware acceleration.

Ok, I reset everything back to defaults and changed ‘decoding’ off CPU to DX3D11VA? and should I leave the multi-threading to single where I have 8 cores? maybe auto? Thanks!

Start with multi-threading set to Auto. If problems go to 8. Same thing with Encoding since that is more important for good recordings. Always check the CPU load what is happening. Also when going to hardware acceleration check Task Manager and the GPU (Graphics) load. If GPU do not start you might need to restart NCS.

Ok, all set - so far my issue hasn’t reoccured! Thanks Henrik.

Hi unfortunately it is still occurring. (see truck below) Also I noticed a 19+ GB of 25MB files filling up my \AppData\Apps\1.0\ folder - are these related to NCS?



The files looks like files for Windows updates. Go to the actual folder and check properties. Use Disk Cleanup and see if they are deleted.
Files for Netcam Studio are always in a separate folder named Moonware.
Concerning the image you need to go through both settings in the camera and NCS. Test VBR and a higher number on Image quality.

Using Process Monitor I confirmed NetcamStudio is creating those files, 25MB each, over and over, until eventually after a few days it fills my drive. (see below)

Thanks for further information! I have sent this to our developers for investigation.
To investigate what happens I would appreciate if you can help me with the following:
-If you open one of these files are they empty?
-Is this the only process running for NCS X or can you see more NCS processes?
-I assume that you have motion detection or recording or … enabled. If you disabled all these is it still generating files?
-If you disable all cameras. Still generating files?


Notepad++ opens them with a repeated NULL over and over on a single line. They do not play in VLC, so it does seem like they are empty. The only process running is NCS X. I have motion enabled on all of my cameras but I’ll delete the files and turn off motion detection and see if they continue. I’ll report back, it usually takes some time for the files to reappear after I delete them.


Even with motion disabled, those files reappear immediately after I restarted NCS X. Looks like they are created shortly or immediately after the application begins.