Camera disconnectión

Hi, I have some wireless cameras as well as a old tablet working as a camera.
Sometimes on wireless reoots or signal lose cameras get disconected and dont come back unless I reset de computer running Netcamstudio or go to the administrator and disable/enable the camera.

I dont I have it set so it mails me on disconnection, Is there a way to manualy set it to retry conenction to the camera. Also It would be very improtant and great some marking on the timeline to indicate the period in withch there was no video inputo and some events may be missing from being recorded, so you dont asume nothing happened, but are aware footage may be missing.

Netcam Studio tries to reconnect all the time if connection lost. Look in the Event Viewer where you have reconnect. However, quite often when it cannot reconnect it is the wifi link or the camera that must be re-initiated to connect again. Most likely you have a bad wifi connection.

Hi, I recently purchased the 16 camera license and have exactly the same issue.
All my 7 cameras are disconnecting randomly and they are NOT reconnecting automatically.
The only way to make them work again, as said already by Pablo, is to manually disable and re-enable the sources.
It is happening roughly twice a day and with cameras that are very near to the router.
I set up the email notification when this happens but it is becoming frustrating.
The cameras are mostly all Dafang/Xiaofang which worked perfectly under Ivideon server.
Any help is appreciated. I can send all the logs if it is necessary as I really like Netcam Studio and would like it to be more stable.


Yes this is tricky. Since the camera is close to the router I would appreciate if you can connect at least one camera with cable to the router so we can remove one uncertainty in this.
Make sure the h264 in the camera work on base or baseline. Check also if any diffetence working on rtsp,_tcp or rtsp_udp in the tab for Custom URL.
Change to an URL with the mjpeg protocol if the camera can use that.

Hi Henrik,

All cameras I have are wireless, no option for cable.
What do you mean about the h264 as base or baseline?
It seems I cannot use mjpeg but I successfully connected the camera using the option RTSP_TCP, RTSP_UDP,RTSP_HTPP and MPEG4.
Which one is the best and how this should solve the issue practically?


Do you have a link to the specs for the camera.
What URL do you use?
Login to the camera and for video it is sometimes possible for h264 select different coding.
The protocols use different hardware and rtsp is usually more sensitive for errors. Mpeg4 is usually less sensitive.

I am using the firmware mentioned in this page:

I noticed other users in the forum have this camera and firmware.
I now changed to Mpeg4, let’s see the results. Never had any issues in the past with rtsp tcp and other software though.

Hi, I’ve got 3 cameras disconnected all at once.
Checking the logs, this is what I found:

Error while cloning received frame
Exception Detail: System.Runtime.InteropServices.ExternalException (0x80004005): A generic error occurred in GDI+.
at System.Drawing.Bitmap.LockBits(Rectangle rect, ImageLockMode flags, PixelFormat format, BitmapData bitmapData)
at System.Drawing.Bitmap.LockBits(Rectangle rect, ImageLockMode flags, PixelFormat format)
at .a.(Object , VideoFrameEventArgs )
Got RTSP Frame [7/1/0420 10:34:11 PM] [1860592] but none has been transmitted since [7/1/0420 10:30:30 PM]

Of course, no automatic reconnection. Tne CPU stays at around 10 %.
I don’t know what do anymore. I did also a fresh install following your instructions somewhere in the forum.
I cannot use this server like that…

No reconnection because the camera sends bad data. As you say above that other user have this camera and firmware and it works maybe it is the camera you should check.

Not sure what kind of bad data. Truth is that manually disabling/enabling the camera solves the issue.
It would be nice if this can be implemented at least as part of the actions in the rules. For some reason, the wake up command doesn’t work properly with some cameras.
Anyway, I will continue to experiment with different settings.
Also, is it possible to download previous versions of Netcam Studio?

Thanks for your help.

Have you reinstalled the firmware on one of the cameras?
Add the problem on GitHub.
When the camera is disabled/enabled the h264 encoder in the camera is reset and it will work for a while.
If you have a license you are free to run any version you like that you have saved, but support is only given on latest release.

I have a license, but where can I find the previous versions to download?



I just found this thread so I thought I add my comment.

A short while ago Netcam Studio asked me to update to 1.9.2 (I was on 1.9.0) so I did.
With this version I had the same problems with various cameras (all using RTSP).
Looks like the one with the highest distance to the wifi was the worst one.
When I was “lucky” I got a red screen telling me that it can’t connect.
Most of the time just the last image was shown. So not obvious to see that it’s not working.
Stopping and restarting the camera always helped.
But this is useless so I went back to 1.9.0 (never tried 1.9.1) and everything is working fine again.
I hope this will be fixed with the next version of Netcam Studio.


Hi Erik,
Thanks for info.
If you go to version 1.9.2 again test to increase the Decoding Buffer in Setteings - Decofing.
What cameras is it?
Would it be possible to get access to the camera for us to test?

Hi Henrik,

sorry for the late reply.
I’m away for a while so my access is a bit restricted.
I tried the 1.9.2 again and I increased the decoding buffer.
But it didn’t help so I’m back to the old version again.
The camera giving me the most trouble is a Foscam FI9900P
But this one is also the one with the largest distance to the wifi AP
The other cameras I use are also Foscams (FI9828W , C1)


Hi Erik and thanks for info.
I have done some testing and it mght be the rtsp over tcp with error correction that have som problems. Change to rtsp over udp in the Custom URL or in the Profile for ONVIF which might work better or mjpeg if you don’t need audio.