Camera loses connection after a short time

I would appreciate any help.
I have a camera that works fine on my network but I cant get a second camera to connect for any length of time. Ive tried two and they both work with their mobile apps but not with Netcam.
The only difference is the second camera is 25 metres away.
Could this be the problem?

Many thanks for any help anyone can provide.

It can be a problem if it the camera is connected with wifi and the signal is low. Connect that camera also with LAN cable and test. I assume the two cameras are of the same brand and model. What camera is it?

Many thanks for your reply Henrik.
The cameras are both wired via the Router and network switch.
The one that works is a Floureon.
The two that fail are a 5mp Misecu which is not on the Netcam list.
The other is a 5Mp Reolink which is on the list.
They both work fine with the mobile app and I can see either of them on their IP addresses on my network.

New cams are not in the listing since they support the ONVIF standard. When you add the camera use the tab for ONVIF Source and click on Browse. The cams should be in the listing.

Thanks again Henrik.
The new camera I bought, a Reolink, is in the Netcam profiles but wont connect. Using Onvif produces a small preview. Ive tried all the profiles with the same result.
The strange thing is I`ve had both cameras connect for a short period of time on Netcam
and both the mobile apps flawlessly.

Thanks again

So far so good :slight_smile: Do not connect the camera at the same time to both NCS and mobile app since the camera might not be able to produce dual streams.
For the small preview it depends on how ONVIF in the cameras is configured. Reolink is quite standardized and they use these two URLs:
Main Stream: rtsp://admin:password@ip_address:554/h264Preview_01_main
Sub Stream: rtsp://admin:password@ip_address:554/h264Preview_01_sub

For the camera with the small preview go to the tab for Custom URL. Set stream type to rtsp_tcp. In address use the URL above for the Main Stream.

Success Henrik!
I tried again with the new Reolink on Onvid and works great.
I suspect the Misecu is the issue with the small preview.
Many thanks again for your kind help, it`s very much appreciated and all the time I am learning which I welcome.
Kind regards,

1 Like