Camera video disappeared

After changing the recording location to the UCN address recommended by Admin, everything worked great. Recordings were being saved to my NAS (previous post “Need answers before buying”). However, I noticed one of my camera video black out. I verified that the camera is producing the video by logging into the camera URL itself. So I decided to shutdown Netcam Studio When I restarted the “Netcam Studio X (Server) 64-bits”, all the logs that scrolled through the console log look OK. However, when I click on the camera views, they were all blanks. It seems that program is running because the motion recordings are still being saved–videos are continuing to be saved on my NAS even though I can’t see any of the 7 camera feeds. I even tried rebooting my PC but still the same result. Within the console, when I click to select the camera source, it is empty. When I go look at the recording location that I just changed earlier, it is empty as well–but it is saving the recordings to my NAS location as I indicated before (\\Public). Also, the Event Logs is empty, the CPU at 0% and the Free Space: 0MB. I noticed that the icon in the task menu said “Netcam Studio Server is Stopped”. If I shutdown the Netcam program and try to restart it, the console log said "Netcam Studio Server Host is already loaded! (Console and Service version cannot run at the same time). I verified that the service is not running on my Win8.1 machine. I tried just loading the “'client” but it won’t accept any password I have tried (did not change password after the new install of from the previous version 0.9.x.x.

Any idea?


Looks like there is another instance of NCS running if the server cannot go online if you have this warning about host already loaded. Just ensure that the service is set to manual or disabled and restart your computer, it can be from another user account.

Also note that


is not a valid UNC

it should be


Therefore the library is probably broken in such state. Try to rollback the change to local folder if you still have issues.

Ok, I see a problem on startup when UNC path is used in the library. This is a regression problem that I will fix for 1.0.6.

In the meantime, open C:\ProgramData\Moonware\Netcam Studio\Server\server.config and put back the library to a local folder to solve the problem.

Yes, I did do the “\192.x.x.x”. I will put it back to the local folder tonight. Thanks.

It is a double “”. This forum is removing one of them so it probably think it is a special/escape character.

In the meantime, it’s still possible to use a network drive if it’s mapped to a local drive letter but will be released probably later today…

Thanks for the update. I will probably wait for It “may” be able to saved to a mapped drive by just typing the letter. If I remember it correctly, the mapped drive is not displayed as part of the selectable drive when you browse the PC (haven’t switch my config back yet to see).

1.0.6 is available here if you want to try:

I have installed the new version and it seems to be working fine at this point. Will continue checking it out for a day or two before making the purchase. Thanks for the great supports.