Cannot access remotely

I have set up Netcam Studio 1.1.0 RC2, with all settings as required:

  1. Opened TCP ports 8100 and 8124 on router - checked with, and they are open.
  2. Have a static IP address for my PC - ports are directed to that IP.

I have tried the Admin account, plus second account, using to log in. Get “Connection Refused” message.
Also tried my external IP Address in browser - - “This web page is not available”.
Uninstalled 64 bit version, then installed 32 bit version - same results.

Event log:
New User connected: Admin from [1]
Listening @ http://localhost:8124/Soap [soapEndpoint]
Listening @ http://localhost:8124/Json |jsonEndpoint]
Listening @ net.tcp://localhost:8120/Moonware/ [netTcpEndpoint]
Moonware WCF Server Started. …
Starting Local Audio Capture Thread
Web Server started on port 8100
Initializing MoonwareServerWeb
RuleManager Created
Creating Instance of EmailSender Plugin. …
Creating Instance of Google Drive Plugin. …
Creating Instance of Dropbox Plugin. …
Creating Instance of FTP Plugin. …
Creating Instance of NAS Plugin. …
Creating Instance of simple FTP uploader. …
15 Source Plugins Loaded in AvailablePlugins [SourcePlugins] . …
Adding Watermark Filter…
Adding MP3 Audio Stream Encoder…
Adding Live Stream Encoder…
Adding TimeLapse Encoder…
Adding FFMPEG File Encoder…
Adding MJPEG Stream Encoder…
Adding LPR. …
Adding Audio Detector…
Adding Motion Detector…
Adding NetCam Provider…
Adding Special Provider…
Adding DirectShow Provider…
1882 Network Camera Templates Loaded…
UserData Folder >> C:\ProgramData\Moonware\Netcam Studio\S…
Applicafion Folder >> C:\Program Files (x86)\Netcam Studio
Initilizing MoonwareServer
Initializing MoonwareServerWCF
SetThreadExecufionState succeeded. PC will not enter sleep mod…

I presume I should be able to log in via browser/external address on the same network where Netcam Studio is running?

Any help will be greatly appreciated

Hi Jim!
Try disabling windows firewall. If it works - then enable it back, and open port 8100 using one of these instructions:
for windows 7
for windows 8

Hi Mikhail,
Should have mentioned it before - I did try disabling Windows firewall, but that made no difference.

Ok, then let’s follow these steps:

  1. using command
    netstat -aon | more
    make sure there’s a line
  2. try opening web page using ip address of interface which is connected to router.
    E.g., my computer has ethernet ip and wireless ip - last one is connected to router. So, I open - It’s on your computer, to make sure server is listening on correct port and interface.
  3. Make sure mapping on your router is correct,
    protocol: tcp, external ip:8100 -> correct computer ip:8100

Hi Mikhail,

Did the following:

  1. netstat shows the line TCP
  2. Not sure what you meant by connecting via wireless ip, but I did connect to my pc ( from another pc connected to the router, and that worked correctly.
  3. Yes, both external and internal ports are TCP 8100.

This really is a mystery.
What next?


Hi Jim!
I’m sure packets don’t reach computer for some reasons.
Any chance to run tcpdump on router?
You can also install Wireshark on your computer and check if any packets from outside reach netcam studio server.

I’ve just tried same configuration on my computer and router and it works:


Hi Mikhail,
tcpdump, Windows version, does not seem able to access the router under Windows 8.1. Only works for versions up to Vista.

I tried Wireshark, but I don’t know what I’m looking for. I don’t see any access to my router, only the local network interface. Lines that refer to port 8100 below:
18 4.534113000 TCP 66 3451→8100 [SYN] Seq=0 Win=8192 Len=0 MSS=1460 WS=256 SACK_PERM=1
57 7.537780000 TCP 66 [TCP Retransmission] 3451→8100 [SYN] Seq=0 Win=8192 Len=0 MSS=1460 WS=256 SACK_PERM=1

Line 18 appears twice (coloured grey) and line 57 appears 4 times (coloured black). I can’t include a screen shot because I am a “new” user.

I may have to give up at this point, but I will probably be getting a new router in a week or two. My current router is a digital one Netgear DEVG2020), and I will be going back to an analogue ADSL2+ modem - perhaps that is part of the problem? Should not make a difference.

Anyway, I will try again when I get the new router (unless you have some other suggestion).

Thanks for your efforts.

Hi Jim!
These 2 lines don’t tell me much, I don’t see incoming connection from Use this filter: “tcp.dstport==8100 || tcp.srcport==8100”.
TCP SYN is an attempt to establish connection. It must be followed by ACK.
At the moment I have 2 suggestions -

  1. router drops packets
  2. Your ISP drops packets - some providers block non-standard ports.

Wireshark shows traffic which goes to your computer, it cannot show what’s received by router.
You need one of these:

  1. router with custom firmware, e.g. openwrt to run tcpdump on it.
  2. connect your computer to internet directly, without router. In this case Wireshark will show if you receive any packets from outside world.