Cleanup fails for SyncNetwork plugin with wrong path

I’ve been using NetCam Studio for some times but only recently discovered the “Network Sync” capability. However, I also discovered an issue with it:
I’ve installed NCS in the default “C:\Program Files\Netcam Studio - 64-bit” directory and setup my library in “E:\Srv”. I also want to sync the videos to my \\\dir$\NetCam file server but I want the cleanup to also occur on the remote file server when I remove a file from the library.
I’ve sucessfully setup this all but when I ask it to delete a video, I get the following error message in the log (translated for the French part):
Failed to remove Recordings\20210923\Recording_0_20210923_121547_550.mp4: Impossible [to find part of the path] ‘C:\Program Files\Netcam Studio - 64-bit\Recordings\20210923\Recording_0_20210923_121547_550.mp4’.
This is normal as no recording is set there, it’s supposed to delete the file from “\\\dir$\NetCam\Motion\20210923\12\Recording_0_20210923_121547_550.mp4”.
I do believe it’s a variable mismatch somewhere in the cleanup code.
Thanks for your help

In Settings and Library tab default is C:\ProgramData\Moonware\Netcam Studio\Server\Library That´s where files are stored. If you set that to E:\Srv, E must be a harddrive on the computer. It cannot be an external drive. Then you must use the absolute path.
Where do yo use \\\dir$\NetCam ?

Thanks for your answer.
E:\Srv is indeed located on a local SSD drive.
I set the \\\dir$\NetCam in Notifications & Synchronization/Network Synchronization settings/Remote Path.
Here is how I set it:

I enabled the Network sync. Please note that disabling cleanup does not change anything.
Recordings propagations work fine. However, when I remove a file from the library in the application, it generates this error in the logs and the files deletions are not propagated:

The error disappears as soon as I disable the network sync.

I must admit that the presence of the error despite the presence of the disableCleanup flag throws me off…

It might be the $ that is the problem. Special characters in .NET Framework can cause problems.

Thanks, I’ll try this, but folder names ending by $ are the sign of hidden shares for Windows. They are an officially supported character.
If this would be the issue, then it should really be considered as a bug.
A great alternative would be to make an SFTP transfer plugin available. Clear text FTP has been obsolete for very long and SFTP/SCP is a much safer solution (providing a certificate can be used instead of a password).

OK, I just tried, using srv instead of srv$ doesnt change anything. It’s not it…

I am using this to my NAS and it works well.
Test to use the public IP number instead of DDNS.
Available FTP protocols are
If you run NCS as a service you must login the service to an admin account since it will use the network.

Thanks @Henrik, my apologies, I didn’t see this option, I’m still discovering the product.
There’s only one issue with it: it only supports password authentication, not certificate. Well, that’s already better than nothing and I’ll test it now.

I’m sorry but it seems that this SFTP plugin only uses obsolete encryption and hash protocols. Here’s the log from my server:
sshd[1545209]: Unable to negotiate with X.Y.Z.T port 60028: no matching key exchange method found. Their offer: diffie-hellman-group1-sha1,diffie-hellman-group14-sha1 [preauth]
It would only be usable if up-to-date protocols were supported (as well as key exchange, not only password). I have to ho back to network sync and manual deletion for now :frowning:

Thanks for info. I have to check this.

Hi @Henrik ,
Did you manage to get any answer on a possible protocole upgrade?

Sorry, nothing yet.

Hi @Henrik, do you have any visibility on the content and date of a new version that would solve this issue?

Sorry, but you seems to be quite alone about this problem. So question is what the problem is.

This is the problem.

It occurs every time I delete videos from the Library if I have network synchronization active. As I already mentioned, I’m unable to test with SFTP synchronization because the encryption protocols of NetCam for SFTP are obsolete (this is the second par of my request: when will the cyphers of NetCam be updated?).

Again, I don’t know why it’s trying to delete anything in" C:\WINDOWS\System32" as NetCam is installed in “C:\Program Files\Netcam Studio - 64-bit”, the library is in “F:\Srv” and the remote storage is in “\\dir$\NetCam”.

The only explanation I see is that you have a mix up somewhere in the variables that drive the cleanup process.


I have checked this and the manual delete get the same error in win10. I´ll be back.