Cloudflare tunnel help

Update: I figured it out, when checking logs in NCS it was showing a bunch of SSl errors so I checked the advanced settings in the Cloudflare tunnel and noticed there was a setting to add my SSL domain for the certificate expected and it works. Hopefully I can help someone else.

I currently use an SSL certificate with my camera streams and open port 8100 in my router.
I want to increase security and close the port while still maintaining access to the camera urls. I have setup a Cloudflare tunnel pointing to my network with the 8100 port and it reports as “Healthy” from Cloudflare edge.
I am using the same url that currently works but stripping out the port: “”.

Do i need to disable the SSL cert?

I just can’t figure out what else to do to get this working…any help appreciated.

1 Like

Thanks for the update! Glad it works.
Just to clarify. Did you also change NCS working port number from 8100 to 443 or 80 in the NCS configuration file or did you a port translation from 443 to 8100 in the router?

Neither, the port translation is done within the ‘cloudflared’ local application installed at the endpoint.

I closed port 8100.

1 Like