Configuration System Failed to Initialize


Good afternoon. I’ve been using Netcam studio for a long time (was using Webcam XP before it) and I love it. That said, today, my machine gave the error, “Configuration system failed to initialize.” I rebooted the machine, still get the same error. I downloaded the latest install file and “repaired” it, same issue. I then uninstalled it and reinstalled it, still the same issue. Help! I have no cameras right now! Thanks!


Hi Neal,

Most likely NCS was just ended (not Exit) at a reboot or restart with an open file. This can corrupt the Configuration file. When you do an uninstall you use the option to Remove. This leaves some config files on the computer for easy update. These files need to be removed manually. Make sure that the Folder C:\ProgramData\Moonware\Netcam Studio\Server is empty. If you have the recorded files stored in the Library folder Library and want to keep them, leave that folder and backup. Now make a new installation of NCS. You need to add the cameras again. Go to the settings for Library and enter location of the old folder and NCS will start to reindex these files.

Hope this helps,


Hi. This didn’t work. I cleared out the folder after removing the program and I still get the same error after a new install.


Hn, it has been working before so the question is what happened just before it stopped working? What you say is that NCS will not start at all? Can you take a screen dump of this “Configuration system failed to initialize.” and post here.
What OS are you running? Was it a Windows update and after that something happened or did you install something else. Check if you have some antivirus running since that have sometimes caused problems.
I was checking back here and you had these problems with the clicking sound. Whats was the problem there?

These are my ideas just now.


Hi Henrik. I didn’t change anything on the system to cause this.

There are two screenshots. I found an old version ( installation file on my computer. I installed that after removing the 1.6.1 files as you suggested and I can get to run properly. I was also able to restore my camera configs to it. I tried to upgrade to 1.6.1 when opening the old version but it still shows the same error as attached above.


I forgot to mention, I even went through the registry and deleted all mentions of “netcam” there. Even after that, 1.6.1 still won’t run.


To answer your other questions: I’m running Windows. No updates were installed to cause this. I’m not running anti virus on this machine. The clicking sound is still present. We never found the fix. I’m not worried about that as much as I am worried about NCS not working at all. Thanks!


Mysterious ways :slight_smile:
Thanks for info. Several things here
1.Crash report not coming through correct. Have to check on that.
2.NCS 143 works, but not 161/162.
3.Which Windows is it? 7 or 10 or server 20xx?
4.Can you check the Event Viewer. When you start NCS and it crashed you should have an Event with an error for NCS in System or Application. The General information below that is of interest. There we should see what goes wrong. Put a image of that there, please.



Thanks. I’m running Windows 10. I looked in event viewer and dont see anything that mentions errors for NCS.


“Configuration system …” NCS 162 need .NET Framework 4.6 or higher to work. NCS 143 use lower versions of that. Can something have happened with .NET Framework 4.6?


maybe. I’m wiping the machine and starting from fresh. This should fix it!


Good idea. Maybe the clicking sound will disappear also.


Things are back to normal now. i’m running the latest version of NCS and things are stable. I even took the time to change the way my network is laid out while the computer was down for a couple hours. The clicking sound still persists but I didn’t think it would go away. Thanks!


Excellent! If you are happy, I am happy? Here in Brazil it is Saturday night so I am out of here for a cerveja :slight_smile:
Have a good one!


I had this same problem after installing an older version that was linked from my license registration email. It prompted me to upgrade to the latest version, which I did, but then would not start again. The last steps from this page fixed the issue!


Here are the steps:

  1. Head to C: \ Users \ username \ AppData \ Local \ appname on your Windows 10.
    Delete the app config file.

  2. Head to C: \ Users \ username \ AppData \ Roaming \ appname on your Windows 10.
    Delete the app config file.

  3. Restart your app and check if the error still occurs.


This happened to me today after a hang/reboot. Step one was all that I required. (Well, and step 3).

Looking at the existing config file, it was clearly only half there.


Thank you - this worked fore me.


Perfect solution for me… thanks