Connecting vStarCam C7824WIP


I brought this camera but the eye4 software has very poor record quality and motion recording does not work properly so i am trying to connect with NetCam Studio but can’t get any picture or audio

the rtsp feed is rtsp://

i entered rtsp://user:pass@ in custom url but camera will not connect
i have tried all stream types but none will work, what am i doing wrong please?

camera home page:

Hi Winston!
I would say that most certainly the URL is not correct. The URL seems a little bit odd to me. Where did you find that? Was it here I see they use UDP so did you set stream type to rtsp_udp ?

I also see that to get audio and video they say Secondary stream + Audio: rtsp :confused: / ip: port/udp/av1_1 so in the URLs below it should maybe be /av1_x

Here are my suggestions:

  1. The camera supports the ONVIF standard. When adding a new source use the tab ONVIF Source and search for it there. Hopefully it will find the camera there. If not, continue.
  2. There are 2 things in the URL that I like you to change and test when adding as Custom URL:
    Set Stream Type to rtsp_tcp.
    a. I like you to change udp to tcp
    b. normally cams that support ONVIF use standard ports so I like you to change 10554 to 554 which is standard for rtsp.
    c. or when it is ONVIF it can also be as simple as:
  3. If nothing of the above works I see that the cam have a Hisilicon processor built in. So test

Sometimes you can figure out the correct URL from the configuration in the camera.

Adding a cam is not always straight forward, but I hope some of the suggestions or combinations above will solve the problem.

Good luck and please report back how it goes to help other users in the forum.

Hi Henrik,
Thanks for quick reply!

The URL I got from system configuration, log in via web browser to and use “server push mode” on chrome
camera configuration -> network settings -> basic network settings

there is says RTSP URL which is the URL I quote in first post

I got the camera working last night using custom URL but could only use MJPEG or MPEG4 stream and 640x480 resolution

today I try ONVIF source and it found camera so i added it but still no picture.
I then disconnect all cameras, changed port to 554 and restart NetCam Studio
I add camera again using ONVIF and click save
I still have no picture so I checked custom source and it say RTSP_TCP feed and url rtsp://USER:PASS@

i change feed to UDP and also adjust URL and now it works great, thank you very much for your help! :slight_smile:

Excellent! Just to be clear:
Stream type is rtsp_udp


yes, that is correct

in the camera configuration the port was set to 10554 though so i had to change it to 554 using web browser login

for the ONVIF profile I selected “PROFILE_000 - RTSP_UDP (1280x720)”

I have also found that if I log in with the eye4 mobile app then NCS loses the connection and i have to reboot camera to get it working again, this may be the reason i was having problems connecting last night

Excellent, thanks!

I forgot. Use TCP if you can. UDP do not use packet check and can therefore be of less quality of the stream.

Does anyone know how to get a jpg stream outof these camera?
Not just mjpg or rtsp

Hi there!
Just curious, why jpeg? According to the specs it supports jpeg and what I have found is this URL
I assume then:

this assume that port 80 is default.

Maybe you can find more info in the configuration of the camera.

Good luck,

Fast answer!
Im trying also add the cameras in Fibaro for home automation, so i can have one dashbord open on an ipad on the wall.
But it seems like the fibaro app dosent support mjpg just jpg screenshots =(

Hi, I am also using Vstarcam C7837WIP:
Home page:

When i login form browser the RTSP URL is stated as:

I wanted to use another application like Onvifer or Wirecast stream but my RTSP URL was not working.
THen I changed the port to 554 and it started working, and even using VLC its fine.

However I need to use in this format:

Now if I reverted back to port 10554, its works now.

  1. Can someone explain why switching back to 554 and then to 10554 works for me now ?
  2. I have noticed that UDP works all the time, but TCP is giving problems and works intermittently.

I want to add this in one of the network DVR’s which are ONVIF compatible so want to make sure that settings are correct.



Did you give a try to the new 1.4.1 as well ? We made many improvements around onvif (and now support PTZ over onvif).

Fact it works after switching ports: no explanations

UDP vs TCP: just a remark here, it’s very common to have artefact / decoding issues when using UDP as the packets are not verified and may arrive in the wrong order so for this reason we recommand using RTSP TCP whenever possible.

As you have onvif cameras, we’d love to have your feedback on the new 1.4.1 which should also provide better performances and the all new web client 2.0. You’ll find it in the first topic of the community.

Hi Steve,

Thanks for a quick reply, I tried net cam studio 1.4.1, which looks good as of now?
I will report if I come across any issues.

Also to check that I have two ONVIF cameras in my network, should both be running on same port 554, as I am only able to view one camera and the other one is not showing up ?


Both are reported in Onvif Device Manager ?

Or in what software have you been able to see both showing up ?

Asking this because I also have 1-2 “onvif” cameras (out of 7-8 real onvif cameras) that are advertised so but that no application can discover. Usually if OnvifDM cannot see it find them then no other software will and it also won’t be visible in Netcam Studio.